1.5.2 OCR suddenly returning gibberish


I updated to 1.5.2 this morning, and my first scans on my ScanSnap have returned gibberish. I upped the ScanSnap scanning setting to “Best,” but get the same results.

Tried same pages scanned to Adobe Acrobat Professional and its OCR handled the job without problems.

Is there a problem with this version’s OCR component?

For the time being, in DT Pro Office turn off the Preferences > OCR option to set attributes. (I always have that turned off because I usually do a lot of scans and don’t want to be bothered by requests to enter attributes, during which the OCR queue stops until I respond.)

OCR accuracy will be restored.

Watch the Blog at devon-technologies.com/scripts/wordpress/

Specifically, it’s uncheck “Set Attributes” after “Searchable PDF:” in Preferences. I did so and now have OCR back.


can you confirm that it is still not working asking to ‘convert to searchable pdf’?

Sure, you can convert every PDF or image using this command to a searchable PDF, you should just avoid the Set Attributes option until we’ve released a bug fix release within the next few days.

Strange… using the unckeched ‘Set Attributes option’ I still see garbage in text if I select a PDF and I use ‘convert to searchable pdf’, while the import from scanner is working fine…

Convert to searchable PDF always sets the attributes based on the data of the selected records.
And the glitch is caused by the PDF generated by the latest version of the IRIS RDE. Somehow the Apple PDFKit and this PDF don’t like each other. The text layer will also be garbled if you edit the PDF in Preview by for instance adding a keyword. We will try to remedy this situation ASAP.