2.0.4 keeps crashing - link to previous version ?


after installing DTPO 2.0.4. from the internal software update, it keeps crashing whenever I scroll a PDF in three pane view. As I am in the midst of an urgent project, I would appreciate a link to the previous version as an intermediate fix: Where can I download DTPO 2.0.3?


Here’s the link:

devon-technologies.com/files … .3.dmg.zip

Could you send the crash log and all console messages to cgrunenberg - at - devon-technologies.com? Thanks.

on the first look it seems there is a Problem with Afloat / SIMBL, but I rely on that. I’ll send the reports - thanks for the fast answer!

thank you,

Comment: I used to use Afloat, and loved it.

But I could see errors running around in OS X, and not only when using DEVONthink. So I removed Afloat.

My philosophy is to give first priority to stability and reliability, as any convenience or time saved by a hack to the operating system may have to be paid for many times over if the hack causes problems.

We know that OS X is a very stable operating system. But we can’t be sure of that when we install utilities that modify the operating system. Hacks may turn out to alter code in unexpected ways, as third party developers lack Apple’s quality assurance resources, and hacks may break any time Apple modifies code.

I run a pretty stock operating system. I’ve got a couple of small hacks installed, and once in a while I may try out a utility that promises neat things. But at the first sign of errors, out it goes.

OS X requires maintenance to keep it free of “cobwebs” and prevent the accumulation of errors, such as stuck or corrupt cache files, etc. Once in a while I run a utility that performs OS X maintenance operations, such as C ocktail or OnyX (I use C ocktail (it costs to register it), but OnyX is donation ware). These utilities provide a friendly interface to operating system maintenance routines that are built into OS X and could otherwise be run from the Terminal. One caution: make certain that the maintenance utility has been upgraded for the version of OS X that’s installed on your computer, as an older version may cause problems.

My Macs are stable, my databases are rock solid stable and I never see an error repaired when I run Tools > Verify and Repair.

DEVONnote provides a floating window, which I find very convenient for note-taking when I’m working in various applications. I’ve never seen an error resulting from DEVONnote’s floating window, as Christian writes solid code. :slight_smile:

Same here also when scrolling pdfs in other views…
I made a “verify and repair” and no errors were find in databases
@Chris: sent you my crash log

Just to let you know: with 2.0.5 it seems the pdf issue is solved

I think I spoke too early: the first time I tried to open a pdf with 2.0.5 I had no problem but after it ended up crashing…actually I’m back to 2.0.3

This issue is caused by buggy third-party hacks, especially SIMBL stuff like Afloat. Just deinstall/disable them.