2.4.3 won't install

OS X 10.6.8

Trying to install 2.4.3 from within 2.4.2. It downloads, but when I click “install and relaunch” I get an error message, something like: “An error occurred while installing the update. Please try again later.” I tried again later and got the same error message.
Screen shot 2012-12-27 at 2.20.42 PM.png

One additional data point: after the installation fails, I can’t quit DEVONThink through the menu our command-Q. If I bring up the “Force Quit Applications” window, it doesn’t show as “(not responding)”, but that’s the only way I can quit it.

Something is corrupted, which is unfortunate. I suggest you completely uninstall DEVONthink (save your databases and personal data). Make sure all DEVONthink files in ~/Library/Application Support and ~/Library/Preferences are removed. Reboot. Download the product you want from DEVONtechnologies. Install a fresh instance.

I tried downloading a fresh installer instead of updating from within the app. So far things look good.