2MB+ rtf files in DTtoGo

I have fully embraced DevonThink, using it to create all of my lecture notes for the classes I teach, and then syncing the files to my iPad using DevonThink to Go.

I create RTF files and paste in images from PDFs I have (snippets of case materials I use; AND in one class screen shots of rather small thumbnails of Powerpoint slides, so I know when to advance my slides.

Anyways, while these files work great, I have found that if the file is more than about 2MB, it will not view properly in DT to Go. All I get is a blank screen.

I don’t think I am doing anything wrong, and its not as if DTtoGo doesn’t view larger PDFs or other files, but the RTF files with images fail, and force me to break my lecture notes into several smaller files.

Suggestions? Is it a bug? Or am I doing something wrong?

Looking at the files, when I create them they are RTFs, but once the images go into them they are labeled in DT as RTFD. Not sure what that means, or if it is part of the problem.

Sorry, realized I posted this in the wrong forum.

Does anyone from DT look at these posts?

Yes, Did you post it in a different section of the forum?

No, I didn’t repost it. I kind of assumed a mod could move it if it was in the wrong place; but it impacts both DT and DTtoGo. COULD you move it, or do you need me to repost it?

My work around to the problem is to keep files under 2MB when they include images in them, but its kind of frustrating.

I’ll call your post to the attention of the DT To Go developer. He may not have noticed it at this location.

FYI, he’s working on coding to allow creation and editing of rich text within DT To Go.


BTW, I absolutely love DT. This program alone has made the switch to a mac worth it for me. And DTtoGo provides me the ability to take my databases with me!

I just tested this myself and it appeared to work correctly in DTTG. You said that it just loaded a blank page? Did it give any kind of error message?

Also, I believe you said this was also an issue in DEVONthink, or is it only a problem with DTTG?


It is only a problem in DTtoGO.

I create RTF files in DTPro, I copy in images (snapshots from Adobe Acrobat Pro X). Or screen shots. They look perfectly fine in Devon Think (although their file type seems to get changed to RTFD . I sync the files to DTtoGo, and the files come up blank, if the file is larger than 2MB. No error message, just a blank page.

I end up deleting the mobile version, and break the file into smaller parts, and then it works fine. But really frustrating to have to do this, as I rely on DTtoGO for my lecture notes when teaching.

I am running the latest beta of iOS5 (well, I’ll be running the Gold Master seed tomorrow). In case that helps.

It only seems to happen with RTFD files. I just synced a 7MB PDF with no problem at all.

Do you have an example that you could send to us? If so, could you send it to support@devon-technologies.com? Mention this post and I’ll take a look to see if I can figure out what’s happening.

I will do that. Thanks.

Well this is truly annoying. I took files that I had split into smaller ones to avoid the problem, pasted them all into a new file, and synced it to my iPad, and the files are working perfectly fine. Uploaded a 6MB RTFD file and it worked fine, but the same file, when I did the same thing two weeks ago, came up blank on the iPad.

I have tried it on two sets of files that caused me problems, and both are now working.

To the best of knowledge there has not been a DTtoGo upgrade on the iPad, right? (And my iPad has been on the same version of iOS5 for the past several weeks (I’ll be upgrading to Gold Master tonight).

So… right now I don’t have anything to send to you, and feel like a bit of a dolt, in that I can not replicate the problem that has plagued me for the past several weeks. I have a new lecture to write this week, and will create it as one large file, and see what happens.

Thanks so much for your assistance.

Correct, not for a while now, though we hope to have an update soon.

Not a problem! Sometimes strange things happen. But if you do run across it again, please let us know.