3.1.1 update jumping cursor

I had just updated the app about 20 minutes ago. I was typing in a formatted note I started this morning before the update. Just jotting down some thoughts. In the space of one paragraph the cursor jumped to the end of the note a few times and I am pretty sure I lost a few partial sentences somehow.
Not sure if that behaviour was related to any syncing that was going on in the background as I had just opened the app a few minutes after updating. Hopefully this is just a glitch of the first sync after update but I thought it worth reporting.


Thanks for the report!
Is it consistently reproducible?

It is for me. I just had a similar issue typing into a Markdown note on my iPhone. Would happen everytime I opened the file to edit it. Seemed like editing had not locked the file from being updated by the sync process with part of sentences I typed vanishing and the cursor jumping about.

DTTG 3.1.1 (17082), iOS 14.6

1 Like

It may be worth adding information on which sync method you are using. I’ve tried to reproduce what both of you reported, but haven’t yet been successful.

I’m using CloudKit for sync. So far I’ve only experienced it on iPhone XR. I have an iPad and MacBookPro(Catalina) as well, all fully updated.

EDIT: I also use bonjour sync since all three of my devices have spent so much time on the same WiFi this past year.

I just used a iOS shortcut to create a new formatted note prepopulated with some boilerplate text. I typed in one line of text, hit DONE and tried to go back to the home screen. There was some anomalous behaviour at that point. I’ll try to describe it as best I can.
It seemed to show me copies of the note that I had created as I slid three or four instances of the same note (with only the prepopulated text, not my addition) before I got back to the group it was in. I selected the group again and went through those same copies of the note but at the end of that there was just a note with nothing new added.
I retyped the one line of text, hit DONE and it behaved more as expected.
It seems to have settled down again but I’ll second the observation made above that it appears to be related to the sync that’s happening as soon as I open DT.
N.B. I haven’t entered or even opened DT on the iPad or MacBook since I posted this. I’ve just entered these two journal entries in a few stages.

Happening for me too.

Markdown editing on an iPad Pro and iPhone 11 in DTTG3.

It started happening after the latest update. Editing Markdown files didn’t show this behaviour before.

The cursor spontaneously jumps to the end of the text where typing continues BUT several keystrokes are lost from the intended edit when it jumps.

Syncing with DT3 on my desktop and laptop Macs via iCloud (CloudKit) with password protection.

1 Like

So, just to summarize: You open a Markdown document and after a few seconds the insertion mark jumps to the end of the document? And this happens reliably, syncing or not?

1 Like

Yes. Every time I’ve opened a Markdown document since DTTG was updated, this has happened. Furthermore, it happens more than once during an editing session. I cannot identify any provoking factor.

I habitually activate a sync in both DT and DTTG when I’m opening and closing the apps.

Just curious if you’re using the software keyboard or an external one.

Software KB on both.

I’m having the same problem. Been happening consistently after the update. Quite maddening. I can also confirm it’s happening with RTF and Markdown files and with the software and a Bluetooth-connected keyboard. It seems to be deleting the last 20 characters or so and then dropping down some number of lines. It’s not going all the way to the end of the document, though. Is there a way to back out this update without having to delete and re-sync everything? It’s making my iPad almost unusable with DTTG.

I was able to capture a screen recording of this behavior. You can view it here:
www icloud . com/photos/#0FbLIiFPkLW0w6ow4YwqrbOqA (sorry it won’t let me include links, so you’ll need to piece it together)

You can see the cursor periodically dropping to the bottom in the first few minutes. Toward the end, you’ll see the whole delete thing happening repeatedly. I have no idea what is triggering it or why my text in the first few minutes was not impacted, but then it kept happening back-to-back. Hope this helps.

Welcome @Charlesaraujo

Do you have a database importing the background or have you made considerable changes to a database that may be syncing in the background?

I sync, using the new version of CloudKit, between my iPad, iPhone and Mac. There are constant additions being made to the databases (just normal daily use), but nothing I’d consider “considerable changes.” As I’m sitting here working on this research, I’m not using either of the other two devices, so after the initial sync, the only thing that should be sync’ing at this point are the changes coming from the iPad. Does that answer your question?

I haven’t seen the behavior here but we are looking into it. Thanks for your patience, assistance, and understanding

We have been able to reproduce the issue and are now investigating.


Good luck!

Hopefully fixed for the next maintenance release.


Cool bananas.