AAAAARRRGGGHH!!!

An hour and ahlf’s work down the tubes because this piece of software doesn’t properly interface with the file system! I created a new text file in DevonThink, opened it in NisusWriter and wrote. And wrote. Saving regularly. And wrote. Then quit NisusWriter. Back in DevonThink the file was completely unchanged. It was empty. If DevonThink doesn’t start to relate more closely to the real file system soon I’m going to be an ex-user. This is getting to be a dangerous piece of software.

Andy:

Don’t assume that OS X is a magic file system that automatically integrates all file types with all applications. It simply doesn’t. :slight_smile:

That’s not DEVONthink’s fault. It’s simply a dangerous assumption to make. Could you create a Keynote presentation using the approach you took? Or an Excel spreadsheet?

The file format used by Nisus Writer Express is not among the list of supported file types. Yes, RTF is supported – but every word processor uses proprietary tricks to do things with RTF.

The safest procedure is to create and edit documents under their parent application. Then you have full control of your Nisus Writer documents. When you press “Save” you can be pretty sure about what happened. (By the way, your saved NWE file is probably somewhere on your HD, but I’m not sure where. Have you tried launching NWE and selecting Open Recent? If it shows up, open it and use Save As to a known location.)

Now, you will probably want to capture the text of your Nisus Writer documents into DT Pro, so that you can search and analyze the text and use all the great features of DT Pro such as See Also. How to do that? The NWE file type is not supported.

You could tell NWE to open your files, save or export them in RTF, then import those RTF files into DT Pro. That’s a bit clumsy and requires more storage space. And the imported RTF files would not link back from DT Pro to the original NWE files.

Here’s another approach, requiring a bit less manual effort, that will both link to the NWE files and capture their text into DT Pro:

[1] In DT Pro, create a new rich text document. Click in the text window. From the Finder, drag the filename or icon of a NWE file onto the text window and drop it. This will create a double-clickable link to the NWE document. Double-click the icon.

[2] In the NWE document, press Command-A to Select All, then Command-C to Copy to the clipboard. Jump back to DT Pro, place the cursor insertion point into the text window and press Command-V to paste the clipboard contents into the DT Pro document.

Now you have captured the text of your NWE document into DT Pro, and have a clickable link back to the NWE document.

About editing: If you need to update the NWE document, open it under NWE, edit it and save it. This will NOT update the text of the corresponding DT Pro document. To do that, you will have to reimport the revised NWE document into DT Pro. You have the choice of deleting the original DT Pro document and replacing it with the revised one, or keeping the original and adding the revised document, perhaps with a version number appended to the document name.

Alternatively, you could import the NWE document using only an external link. That will ‘catalog’ the document, but will not capture its text into DT Pro.

Hope this helps.

I see what you’re talking about. I just did a little test where I created an RTF “foobar” in DEVONthink Pro. Ctrl-clicked on the file in DTP and chose to “Open With…” TextEdit.

In the opened file, I made some changes and saved. TextEdit didn’t complain one bit. Back to DTP and… nothing. The file was unchanged, just as you experienced. Microsoft Word did the same.

I tried it again selecting Mellel (my word processor of choice), and it wouldn’t save. After I made changes (in Mellel) and selected command-s, it gave me a new-document-save-dialog. Probably because Mellel can import and export RTF documents, but does not use it as a native format. Any RTF file would require the new-document-save-dialog, so it’s a false result.

So what was happening? Try command-clicking on the document opened in Word or TextEdit (or presumably Nisus, but I do not own that program) and you’ll see the path of the document you’re working on. And that’s the problem.

You’re not working on the acutal document. It’s a copy. It’s located at Macintosh HD > private > tmp > DEVONthink Pro > jeff > foobar.rtf. And it is just a copy. The problem isn’t with DEVONthink technically, nor with the Mac OS X filesystem, but with the menu labels in DEVONthink. It should read, “open a copy with…” to be completely accurate.

Ideally, it would work like iPhoto and Photoshop. I can double-click on a photo in iPhoto and it opens in Photoshop. After I make changes and save, iPhoto reflects my changes automagically. I would love to be able to choose “edit in external application” in DTP and be able to take advantage of the more sophisticated editing environment of Mellel (which might not ever work because Mellel has its own file format), or Nisus (which uses RTF natively) or even MS Word.

At the end of the day, I disagree that DTP is a dangrous application. It did not meet up to your high expectations, but it is still dang solid, amazingly useful, and pleasant to use… once you grok it. Which I’m sure I have not yet. Which is why, when I try something new, I will double-check that I can take an alternate route before I close anything.

And, when all else fails, blame Bill DeVille. :wink:

terceiro is right on two counts:

[1] Blame me. That’s what support people are for. :slight_smile:

[2] Technically, it is a copy that is opened using the “Open With…” process. That’s a distinction that does become important if you edit the document under another application, as in Andy’s case. If such editing is done and saved, Command-clicking on the document title will display the location to which the save was made. Any time you see “Tmp” in the directory path of a file, TAKE HEED! Although your work is still temporarily available to you, it may not be available in the future.

Andy, if you haven’t restarted or cleaned caches, etc. your work is probably still there in a temporary folder.

As I noted in the prior post, launch Nisus Writer Express and check File > Open Recent. If your document is listed, open it and do Save As to a known location, so that the document is available to you in the Finder. DO THIS NOW. DON’T WAIT.

I have been tracking “newbie” posts to this forum for some time, and it appears that the newer the user, the louder and more imperious the rant. Simmer down a little, guys, and assume that you don’t know everything?

An application like DTP is NOT a substitute for the Finder and its inherent principles. Maybe the program needs a Dancing Baby to appear once in a while and say, “Warning…DTP is not listening to you, if you leave it.”

I have to agree - and disagree. For example, if you’re opening images, PDF/PS/EPS documents or QuickTime movies/sounds (and if you didn’t change the default preferences), then you’re really opening the file. Or if you’re opening indexed/linked files, the command is also opening the files. But it’s only opening a copy if you’re using “Open with…” for plain/rich texts for example. And that’s the reason why this command is not named “Edit with…” but “Open with…”.

However, this will change in V2.0 anyway as all contents will then be file-based.

Any idea when v2.0 will be out? Will file-based contents also allow for Spotlight searches?

Thanks.

We have internal release dates for V2.0 but I can’t publish them - it was a mistake to announce DT Pro too early and we won’t make the same mistake again :wink: However, as DT Personal is already at v1.9.6, you might imagine that DT Pro/Personal 2.0 is not years away.

A file-based structure of .dtBase packages will enhance DT in several ways, e.g.

  • Spotlight support
  • editing externally
  • easy and reliable synchronization of database and filesystem
  • reduced memory usage
  • higher performance
  • improved drag & drop support

And as the memory usage will be reduced, it will of course be possible to open multiple databases at the same time.

Huuuuummm!!! There’s a delicious smell of cake over here…’:D’

OK I was perhaps a little intemperate It happens when you lose work - a VERY rare problem on a Mac. I don’t need a dancing baby, though - a simple word of warning by way of an alert dialog would do.

There’s also a degree of frustration. DevonThink could be EXACTLY what I need. It has potential to burn. I’m glad to see that version 2 will link fully with the file system. When that happens it will be more useful than a really useful thing with added useful devices on a useful mount. Until then, try to take my “rant” as reflecting the disappointment you feel when someone you really like lets you down.

Andy

Thanks Christian! Looking forward to v. 2.0.

Any word on when DT Pro 2.0 might be out. Now I understand why you don’t want to make any promises. But 2006 and 2007 have come and gone. Any indication, even something indeterminate, would be greatly appreciated.

Thanks.

daiyi,

Please see our FAQ as well as my blog for ongoing information about DEVONthink 2.0 and our forthcoming product that is the cause of the delay for and the foundation of DEVONthink 2.0.

Thanks for the reply Eric.