Add as To Do in Omnifocus script

I have a script in DTPO that is listed as Add as To Do in Omnifocus (Extended).

I select a PDF in DTPO I want to remember to come back to in a week and run the script and I can’t find it in OF.

I use the non-Extended version of the same Script and it ends up in my OF Inbox, so I’ll use that one instead.

Just wondering what the (Extended) script is I guess.

That is a custom script you surely have downloaded from here as I did: [url]Alternative "Add as To Do to OmniFocus" script]

With a later release of DtP came an extended/improved version of the built-in script and this custom script has at some point stopped working for me too.
What I loved with the custom script was the option to type in an absolute date.

Kind regards,

My version seems to be working on 10.6

(I’ve fixed a minor string glitch in the display dialog and uploaded it again as version 009).

Another Lion issue ?

How is it failing on your system(s) ?

On 10.7.2 it lets me customize the date and when I press ok the dialogue box goes away and the event is not in OF.

Over here on 10.7.2, when v009 is executed from DTPO ( the first window prompting for the date will appear, but the second window prompting for text does not and no reminder is created in OF. If I execute the script from ScriptDebugger, both windows open and the OF reminder is created. I don’t see anything in the ScriptDebugger logs to indicate problems.

Same here on OS10.6.8 with OF1.9.4. Started with ScriptEditor it works, started from DtPO’s menu it doesn’t. My OS runs in English, so I can exlude an issue with localizations.

And - only when started from DtPO’s menu - when I type an absolute date, I receive “unable to parse 06/12/2011 as a date”. “06.12.2011” or using “11” instead of “2011” doesn’t work either.

Kind regards,

PS: Excuse me getting off topic, but I like how korm is walking the grass on the new board. :slight_smile:

:laughing: :laughing: :laughing:
I almost lost my dinner!!

FWIW have made one minor edit to Ver 010

not sure if it addresses the special context of launching from the DTnp menu.

Thank you! Unfortunately this doesn’t work for me from DT too.

Kind regards,

Sorry, Robin, over here v010 acts the same as v009 – the first dialog is displayed; the second is not displayed; an OF task is not created. Though it works fine with ScriptDebugger.

Seems to be something to do with the calls to System Events. Perhaps if you displayed the dialogs without calling System Events? Perhaps DTPO isn’t playing nicely with System Events?

Certainly worth trying – here’s Ver 011

(The only use of application id “sevs” which can’t, I think, be removed, is the pasting keystroke – the others do look redundant because they are already bracketed by application id “DNtp” – they are a simply a reflex to cope with the fact that some script run environments, Keyboard Maestro in particular, can’t cope with raw calls to functions like display dialog)

That link is not pointing to the download of v011.

Thanks, amended above and here.

Thank you Robin!

Still the same, v011 behaves like the older ones here: It starts with the first screen and after I confirm, nothing happens: No second window, no To Do in OF.
Also I still get “unable to parse 20.12.2011 as a date”.

When I run v011 from the ScriptEditor all works as it should and also absolute dates are accepted.

Something happening when the script is started from DT’s script menu seems to be preventing the correct routine.

Kind regards,