Add from Safari stopped working

For days now I am unable to add web pages from Safari. The scary thing about this is that there is no indication - no error no nothing. I have zero idea how to fix it. It’s shaken my confidence in DEVONthink honestly, assuming I fix it how soon will I notice it’s broken again. Has anyone else had this issue and in particular anyone with any idea how to fix it please? DEVONthink 3.8.3 and Safari 15.0. In case there are multiple ways to send to DevonTHINK I’m using the share icon | add to DEVONthink 3

1 Like

Welcome to the forum.

An aside: as far as confidence goes, sticking to up to date software is something I would strongly suggest - neither DT 3.8.3 nor Safari 15.0 are the current versions of those products (caveat: I can’t be sure of the current version of Safari for each iteration of macOS).

When you use the share sheet to add to DEVONthink 3, the expected behaviour would be for the sorter to open, offering you a range of options, including the format in which you want to capture the page. Does the sorter open? Which settings are you selecting? What are you doing then? If the sorter does open, and you are selecting Add, do you have any smart rules which might be operating on the incoming item?

Also: presumably you have tried rebooting your Mac?

Is DEVONthink open when you select add to DEVONthink 3?

@BLUEFROG: I believe I can confirm a possible bug here: with DT open, selecting add to DEVONthink 3 from the share sheet in Safari opens the sorter, and correctly shares the document with DT. If DT is closed when I select add to DEVONthink 3 though, DT opens, but the sorter does not, and the document is never sent to DT. (I’m not sure this is the OP’s problem, though - it is immediately apparent the document has not been shared, because DT opens and there’s nothing new in the inbox.)

I have confirmed this with our browser extension in 3.8.4 (and we generally advocate using the browser extension).

@aedwards: I’m not sure if this is for you or Criss, since it does involve the Sorter’s Web Clip.

Does using a hotkey to clip a web page work? You can configure a hotkey in the Sorter Preferences if you do not have one already configured.

@BLUEFROG I have just tried chrome and safari extensions for 3.8.4 and both worked ok.

Was DEVONthink was closed when you clipped?

Thanks I can reproduce it when DT is closed

1 Like

I have added fix for this issue and it will included in the next update. @Ellis Does this only happen when DEVONthink is closed?

1 Like

Like any of us would be likely to notice a bug which only occurs when DEVONthink is closed :crazy_face:

3 Likes