Add to DEVONthink in DA not working in Beta 3


I have just installed Beta 3 of DT and unfortunately the “Add to DEVONthink” menu item seems to be no longer working. All I get is a “beep” when I use it :frowning:

This is true of all the options in the “Add to DEVONthink” submenu.

Thank you for any assistance you can give.

See if a login/logout or restart resolves the issue.

Hi Bill

Thank you for your reply. I’ve logged out, logged in and restarted but it makes no difference :frowning:

I just used DA to add a ‘web archive’ to DTPO 2b3 so seems to work for me.

I’ve got DA but hardly ever use it, and your post prompted me to test this function, fully expecting it to fall over. It worked, when I chose the right commands!


I completely removed all traces of DEVONthink and DEVONagent from my computer and then reinstalled them.

Unfortunately the Add to DEVONthink item in the Data menu of DEVONagent still doesn’t work :frowning:

However I’ve noticed that there is a script which does the same thing so I’ve now started using that.

I wonder why this doesn’t work on my computer?

There must be something interfering with it. DEVONagent uses Services to communicate with DEVONthink and when both are installed in an Applications directory, e.g. /Applications or ~/Applications the Finder should notice this and enable the communication. It does not always work properly when you install the apps in other directories, e.g. ~/Download or your Desktop.


Thank you. I do have them both in the /Applications folder.

This Mac they are on has been very hard working over the last few years, a great many things installed and suchlike, so maybe there is some problem with the communication.

I am getting a new Mac in about a fortnight. It’s a new 17" MacBook Pro :slight_smile:

DA and DT Pro will both live on that and I suspect it will be okay then.

One thing to try in your case is to clean the LaunchServices database, this gets messed up frequently when you (un)install many utilities. Use any of the publicly available cache cleaning tools to do this.