Adding messages goes to top-level only

Hi all,

Have searched the forums for this and have found this problem used to exist, but in 1.5 I still see it.

In Mail, when I execute the script to “Add message(s) to DEVONthink”, the message always goes to the top-level in my database, regardless of my preference setting under Preferences->Import->New Notes. I’ve also ticked ‘select new notes automatically’. Have even tried different (and creating new) groups/folders but any selected email message goes to the top-level. Tried having the group actually ‘open’ (i.e., having double-clicked on it) and just ‘selected’, but no go. This is especially problematic in three-pane view as I have to close my groups in order to get access to the top-level and then move the recently-imported mail message to the desired group.

Anyone else having this problem?


David, if you are using DT Pro Office and select one or more messages in Mail, then choose Message > Add to DEVONthink Pro Office, the message(s) will be sent to the group designated in Preferences to receive new content. That works on my computer.

But if you chose in Mail the Mailbox > Add to DEVONthink Pro Office command, the selected mailbox(es) would be copied into an Archive group at the top level in your database.

If you are using DT Pro instead of DT Pro Office the mechanism for capturing a copy of an email is different. At the moment, I don’t remember whether it is sent to the top-level or to a set destination.

One of your comments interested me. You noted having to close your groups in order to get access to the top level. That’s not necessary, as you can have multiple view windows open, as I always do.

In Preferences > General - Interface check the option to always open groups in a new window. Now, if you double-click on a group it will open in a new window. That’s especially useful if you are working on a project group that contains subgroups.

To open a new top-level view, choose File > New Window.

Some scripts do send new content to the top-level view, regardless of Preference settings. Just switch between open views using Exposé – that can be done by swooping the cursor to the top right screen, or by choosing F10 (on a laptop, fn + F10), then click on the image of the desired view. Those are default settings for Exposé in System Preferences, but you can modify them if you like. I find Exposé to be a neat element of OS X. Right now, I’ve got 13 view and document windows open in my database and it only takes a moment to bring the desired on forward.

Note that the Groups panel (Tools > Groups) is convenient for dragging an item to a new group location, even if you are working in a partial view of the database. And because the Groups panel can float above all applications it’s also convenient to drag one or more files and/or folders from the Finder to any desired location in a database.

Terrific! I didn’t even realise DTPO (which I’m running) puts a command in the Message menu, and it even has a keyboard shortcut. Fabulous. And thanks for the tip on using multiple groups - that will actually be quite useful. I had it set to open as separate windows already, but your suggestion could be actually quite useful in terms of a minute-by-minute workflow. I discover more and more about DTPO even month, it seems, largely thanks to these forums…

Nice one, Bill. Thanks, as always.



Is there a way to set a default view for all of your groups in terms of the view you get when you open them in a new window by double clicking (other than opening them all up and setting the view for each one, after which, of course, they will open in whatever that last view was)?


JRPars - once you open up a group once and select your preferred view, the next time you open that group (even after re-launching the app) it should remember your preference. So, in reality, it’s only an issue once.

Actually, not to bring this up again, but for some this has stopped working for me in DTPO 1.5. Immediately after Bill pointed out this menu command, I was able to import several Mail messages into the folder that I selected under Import in preferences. Worked a treat.

Days later, when I just now went to import a few messages, rather than import them, the menu command seems to have just created a new ‘subgroup’ or folder called ‘Inbox’ in the group I originally designated as where I would like to import mail messages.

Can’t explain it. Tried adjusting the import location, but regardless of which group I select, importing one or more mail messages just creates an ‘Inbox’ subgroup (and messages are not contained within that group).

Very odd!

DTPO 1.5
MB 2Ghz, 2GB RAM

EDIT: Tried deleting DTPO plist file but didn’t help. Pretty sure I’ve not changed anything on my system in the last few days, so can’t for the life of me work out what is different. It’s a mystery. :slight_smile:

Standby - I may have fixed…

EDIT: OK, so I’m a little embarrassed. It turns out that I was using the wrong keyboard shortcut. The proper one is CTRL+OPTION+COMMAND+M, where I was doing SHIFT+CTRL+OPTION+COMMAND+M. The latter produces an ‘Inbox’ subgroup wherever you’ve designated your import location.

/me has egg on his face…