Adding PDF docs to DevonThink from DA

I just got DA although I’ve been a long-time DevonThink user. Prior to DA, when I opened up a pdf document via my browser, I was able to select a script (Save PDF from Safari to DevonThink Pro) that would deposit that document into DT.
Now with DA, if I select a search return that has a pdf document, the document opens in DA but I can’t find a way to save it back to DT. There is an option under the Data menu (Add to DevonThink>PDF (Paginated)) that would seem like the logical option, but that doesn’t do anything. So I find that I have to save the pdf to a folder and then drag the pdf from the folder to DT. I’m obviously missing something.
Any help out there? Thanks.

The Add to DT / PDF option in DA works fine for me.

Is the target database open in DT?


Yes. I am using DT Pro. FWIW, if I choose Data>Add to DevonThink>Link, that works fine, but of course, I’m trying to import the entire document, not just the link.

What’s the URL of the page containing the document?

The url is: … 458050.pdf

But the problem occurs with any site that goes directly to a pdf document.

Like Katherine, the command Data > Add to DEVONthink > PDF (Paginated) always works for me. The Name of the PDF that’s saved to the open DEVONthink database will be the URL of the source Web page. (In DEVONthink,I usually change the Name to that of the title of the PDF in its text, by selecting the title text and Command-clicking, then choose the option Set Title As…)

I would suspect that some software exists on your computer that is causing an error. For example, 1PassWord installs an Input Manager plugin that modifies OS X and may cause errors.

Try invoking that command while a PDF page is displayed in DEVONagent. With the Console open, track the messages that are displayed at that time. Sometimes a message refers to the name of an errant piece of software, such as a plugin that’s installed.

That particular PDF won’t download from DA to DTP for me either. The DTP dock icon bounces, but no file appears.

The following appears in console.log:
Nov 20 08:55:57 helen [0x0-0x20f20f].com.devon-technologies.thinkpro[13143]: failed to find start of cross-reference table.
Nov 20 08:55:57 helen [0x0-0x20f20f].com.devon-technologies.thinkpro[13143]: missing or invalid cross-reference trailer.

On further investigation, I’m now having the same problem with other sites, too, including several from which I used to capture PDFs routinely. I suspect a change in Apple’s PDF handling is to blame, but suddenly losing this functionality is a major annoyance.

FWIW, I’m running DTP version 1.5.4, DA version 2.3.1, and Mac OS X version 10.5.5. There are no suspect plugins on my system, and nothing new since the PDF functionality last worked.


Puzzling. I’ve checked this on two Macs, both with DA 2.3.1, but with different versions of DT Pro Office and Leopard. In both cases used DA’s Data > Add to DEVONthink > PDF (Paginated).

  1. ModBook running OS X 10.5.5 and DT Pro Office 2.0 beta 2 (not yet a public release). Saved the PDF from nestorph’s link with no problem.

  2. MacBook Pro running OS X 10.5.1 and DT Pro Office 1.5.1. Saved the PDF from nestorph’s link with no problem.

Did something happen with a combination of intermediate versions of Leopard and DT Pro Office? I can’t check right now.

For further clarification, like Katherine I am running DTP version 1.5.4, DA version 2.3.1, and Mac OS X version 10.5.5. I have two pdf-related plug-ins: Adobe PDFViewer and PDFBrowser.


I always immediately trash the Adobe PDF viewer, which is installed every time Adobe Reader or Acrobat is updated. It’s not necessary to view PDFs under OS X in any application that uses Apple’s PDFKit (or for that matter, Acrobat), and has in the past had a history of causing problems, so I remove it.

I haven’t used PDFBrowser for years. Can’t comment whether it may cause problems currently.

I removed both plug-ins. Same problem.


In my case, removing the Adobe PDF Viewer plug-in solved the problem, both for the link Nestor gave and for other sites.

(I thought I’d killed that one, but apparently the little beast updated itself while I wasn’t watching. Or wasn’t watching closely enough. Harrumph.)

Nestor, did you shut down your browser (including DA) before removing the plug-ins?


Yes, I did although I could try it again.

Second time’s a charm! Works now. Thanks to all for your help.