Adding to DevonThink doesn't work

I only get a system beep when I press the DevonThink button?!

DEVONthink has to be inside the folder /Applications. Otherwise its services don’t work and DEVONagent needs the services. In addition, DEVONthink 1.7.1 is required - this feature does not work with older versions.

sorry, but i have the same problem. i have the newest devonthink version (registered) and the public beta of devonagent (until now not registered, but will do). the devonthink is in the folder applications (dt: progamme) --> devonthink-folder --> devonthink. the devonagent is in the folder applications (dt: programme)–> devonagent-folder --> devonagent.
the button devonthink does not work.
what can be wrong? pls help. thanks

Other possible reasons are installed hacks. During the beta test, APE modules disabled services on a beta tester’s machine and therefore he experienced similar problems. Disabling APE solved the problem. Therefore please check if the DEVONthink services are part of the services menu. Another hack which might cause troubles is MenuCracker.

But if there are no hacks at all installed, please check the system console and if there are any recent entries related to DEVONthink or DEVONagent.

Version 1.0b2c

I’m not sure how DA’s ‘Add selected pages to DEVONthink’ button has been designed to work. In DA’s ‘Pages’ view, I first select (highlight) a page which I wish to add to DT, then click on the above button. This launches DT and brings that application to the front, but does not appear to automatically add the page to DT.

Is there something I need to set in either the DT or DA preferences, or is this button designed only to launch DT so that the page can be manually added somehow?

Note, I also tried selecting a page from the DA ‘Pages’ list, right clicking in DA, and selecting DEVONthink>Add page and Add link, but although the commands were not greyed out, nothing appeared to be added to DT.

David

Which version of DT do you use? At least DT 1.7.1 is required. And is there anything inside the console related to DA or DT?

Works perfectly now :slight_smile: , I was still using version DT 1.7. :-[

Thanks again,

David

Adding to DT does not work for me either. Doesn’t matter  wheather APE’s are installed/disabled or not (I have tested it on two different OS’). By the way: there is nothing related to DA or DT in the console.

German system 10.2.6. (unregistered) DT 1.7.1. DA 1b2 or 1b3.

If you try to add contents to DT, does OS X launch DT at least? If not, please verify the installation of DT:

  1. The DT application has to be located in the folder /Applications (or one of its subdirectories).

  2. Don’t copy the disk image to this folder - you have to copy the contents of the disk images (we’ve seen such a thing on a screenshot lately and this just can’t work)

  3. Log out and in again at least once after the installation of DT.

I am having this problem after upgrading to 10.3.2. If I click on the “DevonThink” toolbar button in DevonAgent, I just get the system beep. Debbuging steps I’ve tried without success:

-Verify DT and DA are in the Applications directory
-Fixing permissions
-Tools>Verify & Repair in DT
-Re-install DA and DT from latest versions (1.1 and 1.7.3 respictively)

Clicking the "DevonThink" toolbar button in DevonAgent causes a brief flurry of disk activity but does not launch DT. However, using the Devonthink>Take [Plain Rich] Note does launch DT and create a new note.

So, this looks like DA has forgotten how to talk to DT. Any ideas on how to correct this? I’ve really gotten used to adding research notes from DA to DT - I’d hate to have to go back to the two-step manual method.

Did you log out and in again since the installation of DT & DA? Are there any APE modules installed? Could you please check if there’s anything inside the system console related to DA or DT?

Finally, one workaround is to drag & drop results from the "Pages" tab (or the archive) to a DEVONthink browser window.

> Did you log out and in again since the installation of DT & DA?
Yes - it did not make a difference.
>Are there any APE modules installed?
Not to my knowledge, but I’m not sure exactly what to look for.

>Could you please check if there’s anything inside the system console related to DA or DT?

Bingo. In my user console log, there’s an entry which corresponds to the times I have unsuccessfully tried to add from DA to DT:

[ashgrove:Logs/Console/davely] davely% grep DEVON *
console.log.0:2003-12-22 09:19:02.345 DEVONagent[658] addRecordsToDEVONthinkHandler: NSPerformService failed
console.log.0:2003-12-22 09:38:32.728 DEVONagent[666] addRecordsToDEVONthinkHandler: NSPerformService failed
console.log.0:2003-12-22 09:41:21.524 DEVONagent[666] Couldn’t convert path “/tmp/Most (if not all), of todayÂs transaction…html” to an FSRef to put on the pasteboard.

The workaround of dragging from DA to DT gets me back on the air - thanks. I still miss being able to add from the DA browser window, though. Any suggestions?

Fruitmenu, Windowshade, Icecoffee or Xounds are APE modules (“haxies”) for example. But according to the log, DEVONagent can’t find the services of DEVONthink. As you’ve logged out/in, it’s difficult to tell why. Maybe bugs of the service system (still buggy under Panther), maybe privileges issues. Do you use an admin account? Is it possible to use the DT services in Safari for example? Then this should work.

I do use an admin account, but was doing so before the problem started. The DT services are working fine in other apps, such as Safari and TextEdit - I can even successfully do a “Take Rich note” from within the DA browser. The problem seems to be strictly with DA’s “Add Selected pages to DevonThink” menu/button. Is there something different about what this button does than what the services do? (I’m specifically thinking of how the URLs get passed, for example.)

Dragging results to DEVONthink is technically almost identical to “DEVONthink > Add Page”. Therefore the problem can’t be related to the data - the service system does not work as expected on your system. Did you modify the service entries of the info.plist file inside DEVONthink’s application package, e.g. to localize it? Or could you send me a list of all installed third party extensions (contextual menu plugins, APE modules, input managers, services, preference panels, hacks/haxies etc.)? Something has to be different on your system.

Another bit of debug data: I tried DA from a different account on my system, and it works fine. The DEVONthink button in DA launches DT and cleanly adds an entry to the database. This suggests it’s not a problem either with the system or the DA and DT applications - its something to do with the settings or databases in my account.

I have tried trashing the com.devon-technologies.agent.plist and com.devon-technologies.think.plist files from my ~Library/Preferences folder, but this didn’t help the problem.

same here. DA and DT new versions, registered some time ago and just downloaded this afternoon. Dragging and dropping from DA into DT works like a charm, but pushing the button just makes a beep. No haxies or weird stuff installed, permissions repaired, etc. The services menu works perfectily in safari.

weird

Woo Hoo! I just downloaded the new versions of DT and DA. After installing, I now have my button back. My installation steps were:

  1. Download and mount .dmi files
  2. Shut down all other running apps
  3. Drag DT and DA (and Easyfind) to /applications
  4. Log out
  5. Log in and run DA and DT, but don’t try adding anything.
  6. Quit DA and DT
  7. Log out

On logging back in, things were working again. keep your fingers crossed!