Alfred workflow: DEVONthink Pro Search

Usage

  • Type dnt + keywords to search in all opened databases.
  • Type dnd to choose which datebase to search
    • Press Enter, then type in keywords to search in the chosen database.
    • Press ⌘Command + Enter to list all tags in the database, then choose a tag and press Enter to list all documents which have the tag.
  • Type dnm + tag1, tag2, … to list all documents which have these tags in all database. Tags inputed must be exact. For example, Tag aBcD can’t be inputed as aBc or abcd

After documents were listed,

  • Press Enter to open the selected result with DEVONthink.
  • Press ⌘Command + Enter to open with external editor.
  • Press ⌥Option + Enter to reveal result in DEVONthink.

You can download if from https://github.com/mpco/AlfredWorkflow-DEVONthink-Search

Interesting. Thanks for the offering.

dnm is working, dnt is not.

Try the latest version ( V4.3 ) in Github.

This looks fantastic. But is it possible to port it to Alfred 4 and Devonthink 3?

I have Alfred 4 and DTP 3 – either the workflow doesn’t work with these versions, or I haven’t set it up correctly. Can anybody help me?

Can you explain exactly what “doesn’t work”? For example, what do you see when you open Alfred and type dnd in the search box?

Stephen

Thanks for your reply. I’m pretty inexperienced with setting up Alfred and DevonThink so I suspect that I have done something wrong.

Alfred searches chrome — for example I typed dtn Kierkegaard and it tried to find such an entry on Google. I haven’t tried dnd , however.

I’m not sure that the workflow is installed on Alfred at all — I don’t see it among my other workflows.

Here’s a screenshot when I tried typing dnd

Also, I am using BigSur OS 11 on my MacBook Pro

I have solved the problem. I found the right workflow version for the configuration I have.

I’m glad you managed to get it sorted.

Stephen