All data lost after rebuild

All told, I’m always encouraged to read (and participate in) good discussion about proper backups - local, online, and offsite, as the need dictates.

From the small series of blog posts I wrote a few years back…

If there’s one difficult question to ask in Support, it’s: “Do you have current local backups of your DEVONthink databases?” Too often, the answer is, “No” or “I’ve been thinking about starting backups, but I need to restore my data now!” This is a heartbreaking response to hear, and one we want to hear less and less.

And I stand by that statement. It is heartbreaking to hear in those instances where you know that’s the only recourse. So good on ya!

1 Like

It is automatically disabled while multiple databases having the same UUID are opened.

To chime in again …

Last night, I was preparing to resurrect lecture notes from last year. I discovered that I had “lost” one page in my lecture notes (FWIW, I use Curio and I had lost an Idea Space in the chapter section). No problem, I thought, I will pull the source file from a Time Machine copy. No luck. The TM backups went to last year at this same date as today. None of the copies had the page. OK, no problem, I will pull the source file from my archive storage … a partition on the same TM backup. Nope. No luck. Same problem.

Long story short. By the time I was done, I found a backup of the source file that I made just last year before I installed Mojave. That “original” file (oddly enough suffixed with the name “original”) had the page. Every copy of the lecture notes from that date forward did not.

I have no idea why. But good fortune smiled on me this time.

So, backup and archive and do TM with diligence. The hard-fought efforts of one day can disappear in an instant, and the loss may not be discovered until some time later when it cannot be resurrected.


I had exactly the same problem with exactly the same procedure and the same result. But me as well could recover the db from time machine.

Happened to me recently as well.

Ended up with 9000 orphaned files. I had a recent backup, though-- and so felt few qualms in restoring, at the expense of a few hours work.
Is there a devonthink log file that might explain what happened?

Note that Bluefrog’s suggestion above, of opening the database while holding the option key and then selecting Restore Backup, to roll back the metadata, worked for me after I was left with 4000 orphaned files. I was presented with three choices of metadata to restore, one with 221MB and two with 4k.

If it happens to me again that would be my first move.


This happened to me me today. I was moving the database from “shared/relocated items” (thanks Apple) to ‘Users’ all seemed well but on opening no records so I then did database verify and rebuild and ended with all records as orphaned. Was able to open a backup database that was on a hard disk.
Scared the **** out of me but ended ok. I can find the 30 odd records lost between back ups because I even back up the data I send to DT using Hazel.

This is IMHO a severe issue of Catalina, over here it relocated files (even system files!) for no good reason after various (beta) updates. Maybe it makes sense to Apple but to me it doesn’t. Where was your database located before it was relocated?

Thanks for your reply: It was located in a separate directory called Databases that I created in the root directory (HDD) in Finder. Seems Apple won’t allowed it anymore. I delayed upgrading to Catalina until last week hoping to pick up these issues in advance but didn’t notice any comment about the auto relocation of directories like mine. Didn’t notice the relocation had happened until I needed to back up the database directory so then tried to move it to a new location Users/Databases etc… which started the original post above.

Was the Databases folder located in your home directory or in the root of the startup volume? Catalina does indeed not like the root directory anymore for user created items. The recommended location is ~/Databases in your home directory, this directory is also created by DEVONthink 3 and the default location.

Databases was created in the root directory of the start up volume (when I first started with DT 2 back in Jan 2016). I am now using the default location for the databases folder (3 databases General, Email and Evernote). To be honest I probably only use about 30% of the functionality DT. For me it’s a place for an organised dump of data (more professionally called a Data Warehouse I suppose) and sync allows me to keep a remote location up to date and it’s backed up also. I explore the functionality as I need but its great to know it’s almost certainly got all the functionality I might ever need.

To be honest I probably only use about 30% of the functionality DT.

And don’t worry about that either. DEVONthink is like Photoshop. You may only scratch the surface, but you use it how you need to use it. And you have the luxury of knowing there is more power under the hood and tools at your disposal for future explorations!