"All Images" and "All PDF" smart groups not finding all files [Resolved, more or less]

Just noticed that the supplied “All Images” and “All PDF Documents” are finding only a small number of my image and PDF files. If I close the database and reopen it, the file counts in the sidebar are 38 and 12, respectively, which are probably the correct numbers (I haven’t actually counted them up).

However, when I select one of those smart groups, the counts change to 2 and 4 respectively, and that is all that shows in the item list. (The counts do not change back in the sidebar when I click to another group.) The files that aren’t being found all have Kind: Adobe Photoshop Elements JPEG File or Kind: PDF+Text, which is exactly the same as the few files that are being found. I also tried changing the smart groups to use extension is JPG or PDF, with the same results.

I have run File> Verify & Repair Database (which did not appear to do anything – should there be any visible dialog or message?) and File > Optimize Database with no change in results. Should I run File > Rebuild Database, or just trash this database and start fresh? (It seems to be jinxed.)

As with my earlier posts, all files are indexed, not imported. DT3b4

A screen capture may be helpful.

I tried rebuilding the database with no effect, so I finally deleted the database and created a new one, first copying all my test files into a new folder and indexing them from there. Now the smart groups are working, and my other issue with searching on the filename has also disappeared.

When I rebuilt the database I got a message initially that the database seemed to be open in another instance of DT or hadn’t been properly closed. I continued with the rebuild since I knew there was no other instance open. I wonder if this message may have been an indication of some kind of corruption not fixed by Verify & Repair or Rebuild.

Usually it wasn’t closed properly, e.g. due to a crash.

Did you exclude any tags from searching, see Search by item name or filename returning no results DT3b4?

That was the problem, sure enough. My group tags (Surnames, Places, and Label Colors) were excluded from searching. I removed the exclusions, and now the Smart Groups show all the images and pdfs. Thanks!