Alternating row colors disappears

Hello,

I have “alternating row colors in views” checked in my preferences, but the alternating colors have disappeared and nothing I do works to restore them. It’s a minor annoyance in terms of getting work done, but I do prefer having the rows in different colors.

Thanks,

Richard

Can you post a screen capture of what you’re referring to?

Here is the screenshot:

Normally, there would be alternating gray and white rows where the folders and files are listed.

The alternating row colors applies to View > as List. This is Column view.

Thanks!

You’re welcome :slight_smile:

“I have “alternating row colors in views” checked in my preferences, but the alternating colors have disappeared and nothing I do works to restore them.” This seems to be the case even when “VIEW > As List” is selected. DTOP 3.3.8 MacOS 12.3.1

The List view on your screenshot actually uses the alternating colors, the sidebar doesn’t use this setting but that’s intended.

Thanks for the reply. However, I still do believe I am not seeing the line alternating colors which I used to have in prior versions of the software. I would like to bring them back. They are selected in preferences. The reason you saw alternating colors in my prior screenshot is likely became there were only two lines and I had manually selected the second line thus producing a blue highlight.

The grey lines in both screenshots are the line alternating colors.

That’s how it always was, I think.

(And yes, as you know, the blue line in your first screenshot was due to this line being selected.)

Thanks Pete - but for the life of me I don’t see the alternating gray lines. I’m beginning to worry about my eyesight now haha. I see a completely uniform white background whereas in prior versions of the application I always had lightly shaded alternating lines. I think I might even have been able to change the colors of these alternating shaded lines back then. At one point I think they were light blue. Now there is no contrast between the lines at all. Not sure what to do to bring it back. Selecting / deselecting the option in preferences (as shown in my screenshot) does absolutely nothing. I have closed the program, rebooted the machine etc. Nothing. So I’m not attaching two screenshots. One with the alternate line color option “on” and one with the selection “off.” Interestingly you see remnants of the lines at the edges of the Preferences window when the option is selected to on. I have highlighted these shadows in red circles. It seems there is an error in the program.

Only allowed one attachment per reply. Here is the screenshot with the selection off and the cray lines disappear around the edges of the window. Note that it makes no difference in the view window whatsoever.

I’m afraid you might be correct with this :frowning:

I can clearly see a difference between your last two screenshots, i.e. altering the preference results in a changed UI.

@stevelabo some ideas come to mind, maybe they might help you to see the difference.

  1. Try to increase the macOS contrast:
  • Open macOS System Preferences (e.g. via Spotlight)
  • Click Accessibility
  • On the left side click Display
  • Click Increase contrast

On macOS 10.14 (Mojave) the difference looks like this:

or

  1. Try to (temporarily) set macOS’ appearance to Dark.
  • Open macOS System Preferences (e.g. via Spotlight)
  • Click General
  • Select Dark

On macOS 10.14 (Mojave) the difference looks like this:

PERFECT. You made my day yeah… Thanks. Contrast slider in Pref > Accessibility > Display > bottom right slider, needs to be all the way to the left IE “normal” mine was just one half ‘notch’ to the right of that (towards the maximum side) - apparently enough to make dramatic differences. I can sleep tonight! hahaha Take care.

2 Likes