Annotations randomly lost!

I’ve just come across a rather annoying issue (?bug) with Devonthink (3.9.4) on Mac (running Sonoma 14.0).

I was reading through an article in the DT preview pane, making annotations as I was going along (by using the “highlight text” tool). These annotations then appeared in the annotations part of the inspector pane (the one under the “document” heading, not “annotations & reminders”). I have noticed that sometimes, when I select a different article, and then come back to this one, the most recent annotations have disappeared - meaning that they’ve disappeared from the annotations pane, and also the text is no longer highlighted. This has now happened 3 times with the same article. I added the annotations again, though after switching to view a different article and then returning to this one, the most recent annotations were again missing!

Any help appreciated.

You shouldn’t be running Sonoma 14.0, if you actually are. Sonoma is already a pile of bugs so it’s even more important to update the OS. The current version is 14.1.1.

Regarding the behavior, I did some thorough investigation on the matter and it’s in development’s hands now.

Thanks @BLUEFROG - were you able to replicate the issue at all? It just happened to me again with a second article. I will update the OS and let you know if that changes anything.

Assuming you’re referring to PDFs, then yes I could consistently reproduce the behavior. However, it’s very likely people may not see it all the time. But for those actively adding PDFs to their database(s), it’s much more possible to be experienced.

PS: The Sonoma update shouldn’t have an effect. But as I said, it’s still a buggy OS (sadly), so make sure you stay up to date. The 14.2 release is in beta 3, so hopefully it will actually fix some more important things.

Interesting, thanks. Yes, the vast majority of my database is PDF. I’m glad you could reproduce the behaviour and hope that the development team can sort it!

It’s another bug of the PDFkit framework and not limited to Sonoma. This affects also Preview.app or Highlights.app. We’ll check if it’s possible to work around this.

…and the next maintenance release will indeed work around it.

3 Likes

From @cgrunenberg Task List:

  • 96% of tasks workaround macOS bugs.
  • 3% of tasks to make real work.

Boss:
– That makes 99%, not 100%.
– Well, I’ve done the calculations with Numbers.

[Alternative ending]
Boss:
– That makes 99%, not 100%.
– Well, I need to pee so and then.

:laughing: :laughing: :laughing: :laughing: :laughing:

5 Likes

Unfortunately that’s indeed my impression more often than not :smiling_face_with_tear::joy:

2 Likes

I’ve had a similar problem. Several times when I tried to summarize annotations to sheet, not only was the summary not produced but all my annotations disappeared. Not sure what caused that, but I’ve made it a practice to click on the name of the annotated file in the item list in the main window before choosing the Summarize Annotations command in the Tools drop down. The problem has not recurred. Initially, I duplicated the annotated pdf to a different folder before summarizing. Turned out that insurance wasn’t needed. I’m running Ventura 13.2.1.

I am having the same problem. I Insert back Link, get the blue line with the link, then go to highlight pdf and the link is gone. If there is other stuff in the Annotations window, it also is gone. Sometimes happens even if I just move my mouse; i.e. don’t even get over to the pdf window and the link is gone. In fact, sometimes is gone almost instantly – mouse does not even get to move and the link is missing.
Latest Devonthink Pro 3.9.6; Mac Sonoma 14.5.

Frustrating

Where and how exactly did you insert the back link and finally go “to highlight pdf”? Additional details would make it easier to reproduce & test this, thanks.

I go to Annotations, click on the little triangle and that leads to the menu where I see Insert Back Link and I click on that item. I do the same thing for Insert Quote. I did nothing new. This is the same way I have done it for ages.

Yesterday I clicked on “Insert Back Link”, the blue link appeared and then either instantaneously disappeared or remained until I went to the associated pdf and clicked on it, at which time the blue Link disappeared. If I put something in the Annotations field (e.g. pasted the Copy Page Link, or wrote a bit of text) it would remain, but when I then used the Back Link or Quote, everything disappeared.

To assist in analyzing the problem, I went to a pdf that was annotated, copied the annotation (just in case), then clicked on the pdf; the annotation text then disappeared. I could paste the text back, but was afraid to try on any other file. I decided to not use annotations until this issue was cleared up. I then came to the Forum, where, from my search of the Forum, this, or slight variations of it, is not a totally new problem.

TODAY, everything is fine! When I went to remind myself of exactly what I did; it worked the way it was supposed to. I did nothing between yesterday and today, except today I had to reopen the database. I don’t remember closing it yesterday but it is possible.
Nevertheless, the issue was present yesterday and was very off-putting.

Screenshots or a screen recording would be really appreciated In case that this should happen again, thanks in advance!

Here is your video.
Happened today.
Had written 3 lines of text in annotation field. Then left the field and went somewhere else on the screen. When I came back the text was gone. Started video at that time. Attached.
This activity seriously compromises my confidence in using annotations, or at least the Annotation menu, as a way to make notes. The attached zip file is a .mov file of what I did. When I went to attach the .mov file it was greyed out, so I compressed it. I hope that is OK.
Screen Recording 2024-06-16 at 2.58.19 PM.zip (9.8 MB)

PS: After submitting the above, I restarted Devonthink and now the issue is not there. This is like the episode I previously described where on Day 1, I had troubles as described, but on the next day, after the database had been closed and reopened, the problem was not there. Today I closed and restarted DT, and reopened the database and the problem is gone. It seems that something is happening with the Database that gets cleared/corrected when the database is closed and reopened. How long this database will function properly is unknown. I did not close it between after the first episode and today; i.e. it was open, but no annotations made, for at least 24 hours.

Do you have any smart rules running, e.g., Filter Duplicates?

Yes. Smart rules running are

  1. Reminders (purpose of which is unclear to me) I opened it to explore and don’t have any need for it to apply to me.
  2. Filter Duplicates
  3. Bates numbering: don’t know what Bates numbering is and don’t intentionally use it
  4. Track Opened documents with Trickster. Not needed but there.
  5. Remove obsolete versions
  6. OCR PDF: Obsolete, and Greyed out
  7. Unify Date in Names, which is a rule I think I wrote that checks the date in the name of a file and if it matches [-9][0-0] or [0-9][0-9][0-9][0-9] THEN Perform Scan Name Date; Change name to Sortable Document, Date Name Without Date.
    I wanted to automatically sort my files into years published, or year Acquired, because my file folder had > 24000 files and was slow to load. It never worked and I left the rule there. I should delete it.
    That is all the Smart Rules.

Control-click this one and choose Disable Actions then see if the behavior continues.

Thanks. I have done so and now will see how it works. Currently all is fine, I will cross my fingers and hope it remains so.

Don

If it does work, what is it about Filter Duplicates that screws things up?

I don’t know that there’s anything screwed up. However, it is a built-in smart rule that moves files to a database’s Trash. It is set to On Demand by default but it could have ben enabled at some point.

PS: Did you check the database’s Trash to see if the documents were ending up there?