Anyone else seeing Moom being MIA with DT3?

Hello all,

Have Moom (v 3.2.22, latest) as my window manager.
DT3 on 3.7.2, macOS on Big Sur on 11.4

Have Moom setup to offer its hexagon grid when hovering over the “green button”, that allows one to select the desired window size, as below:
image

Over the past day or so, this has suddenly stopped working – but only in DT3?
As in, hovering over the “green button” sees no grid appear, and only offers the system-based option of going “full screen” on a different “space”.

AFAIK, nothing changed – I didn’t change anything in the Moom preferences.
And as mentioned, it still works completely as expected with all my other apps.

Would appreciate it is any Moom users can confirm whether things are working as expected their side?

I’m still on Mojave (and can’t test right now) but with my setup it’s quite often necessary to deactivate DEVONthink (e.g. by clicking on the desktop) and to try again whether the Moom overlay is available. Sometimes it takes several rounds of de/activating until I can use Moom again.

I’ve tested with the same setup as you except for the setting on the HOVER option.

I am having no problems.


JJW

Yes, MOOM is Mia for me as well. Im running 11.4 and DT3.

Thanks,

John

Same here frustratingly.

Welcome @jwilkins

Does this persist after rebooting the machine?

Yes, I just tested it.

I think ManyTricks may have to look at this.
The issue is when using the unified window style.

When Help > Documentation > Appendix > Hidden Preferences > WindowToolbarStyleExpanded is enabled, Moom works as expected.

I opened a ticket with ManyTricks on it. Thanks for your patience, assistance, and understanding

3 Likes

Thanks - yes, I’ve noticed similar issues in other apps with the unified style.

Thanks for the info!

I’m in contact with Many Tricks now. Cheers!

Just tried that Terminal fix, and run into a different snag:

Running the following in Terminal, results in the error: zsh: command not found: $

Here be the command I tried to run:
$ defaults write com.devon-technologies.think3 WindowToolbarStyleExpanded -bool TRUE

I am not very familiar with Terminal on Mac – and it has been too long since my days with DOS!
Anyone who can clarify what I am doing wrong?

I got the same error message…

1 Like

I did a bit of light googling, and used the same command – but without the $ in front (i.e., simply start with “defaults…”) – and that appears to have done the trick.

After restarting DT3, Moom is back in action. Maybe that works your side as well!?

It works! Many thanks!

1 Like

I’m a longtime Moom-er, but it’s always seemed to work in DEVONThink. After reading this topic, I hovered my pointer over the green button and the Moom UI did not appear.

I checked the main menu bar to make sure Moom was running. The icon was present, and when I clicked it to confirm, the menu opened as expected.

Back to DEVONThink I go, and now hovering the pointer over the green button invokes the Moom UI.

Not sure what that proves…maybe Moom just dozes off once in a while and has to be jiggled awake?

I have been in contact with our friends at ManyTricks and had some DEVONthink users test a debug build. The build worked for everyone so I’d anticipate an update to Moom in the not too distant future.
Cheers!

2 Likes