Apple Mail 13.0 and DT 3

There is no menu item nor a context item to transfer mail to DT. In Mail preferences, General, Handling of plugins, the pane is blank.

The ~/Library/Mail/Bundles contains the DEVONthink.mailbundle.

You need to make sure to enable Full disk access in System Preferences > Security & Privacy > Privacy for DEVONthink 3.

Also, macOS 10.15 is a ​beta ​operating system. Unless you are explicitly beta testing and reporting, you should not run a beta operating system on a device you need operating as expected.

Full access is enabled. Understand the beta.

Open /Applications/Utilities/Terminal.app and paste: defaults read com.apple.mail EnableBundles and press Return

If it doesn’t return 1 (or it’s possible it could read True), quit Mail and run: defaults write com.apple.mail EnableBundles -bool TRUE.

The EnableBundles variable did not exist, so I closed Mail and did the defaults write. After this I have EnableBundles = 1. Starting Mail and Preferences -> Plugins. The pane is still empty and there is no change in menus or contextual menus.

Please remove the installed plugin ~/Library/Mail/Bundles contains the DEVONthink.mailbundle, afterwards ensure that full disk access is enabled and install it again via DEVONthink 3 > Install Add-Ons. Afterwards it should be available in Preferences > General > Manage Plugins… of Apple Mail.

Sorry, the pane is still empty.
The EnableBundles has effect. Setting it to FALSE results in that the selection “Manage Plugins” disappears. Setting it to TRUE and the button reappears, but the pane is still blank.
All security settings should be set, the full disc access is set. Also rebooted, but result is the same.

We’ll check whether the latest Catalina betas changed something relevant again but it’s definitely not recommended to use betas in production environments.

Thanks.
My data; iMac on 10.15 beta (19A558d), Apple Mail ver 13.0 (3594.4,2)

Any news on this item? Still no sign of the mail-bundle in Mail-app.
macOS 10.15-beta (19A573a)
Mail Version 13.0 (3594.4.13)

Regards
Gunnar

Unfortunately not. We were not able to reproduce the issue so far.

Some updates;

I have done a testinstallation on an external SSD of Catalina (release version). I did not configure my Apple-ID, but apart from this a normal install (for me), ie location Sweden etc. Configured Mail to my second mail-ID and verified functionality and closed the app. After this I downloaded DEVONthink 3.0.1, installed and ran the Install Add-Ins, started Mail and went down Preferences->General->Plug-ins. The window now contains the DEVONthink PlugIn and its selectable and work.

Spurred by this I booted my “real” system. Used CleanMyMac X to remove DEVONthink. Closed Mail, downloaded DEVONthink and installed, ran the Install Add-ons, started Mail, but unfortunately the result is the same as earlier, ie no sign of the Plug-In.

This system has had a long history of updates of the OS and it seems that something is preventing the current Mail-app to see/read/accept the Plug-In. I have tried to peek through the system but cannot find anything.

Just crying out for help and hope you have some idea how I can proceed.

Best regards
Gunnar

Did you try to completely remove the folder ~/Library/Mail/Bundles? Do you have read/write access for ~/Library/Mail? You could also enable full disk access for DEVONthink in system preferences and try to delete the preferences of Mail completely.

I have done this (a couple of times) but result is the same. I should also add to all this that my Macbook Air behaves exactly the same as my iMac, ie no trace of the Mailbundle in Mail-Prefs.

Today I created a new user on my iMac and for this user the mailbundle appeared as soon as I had created a mailaccount.

To me, this appears as the installation of macOS etc is correct and the problem resides with the user “gunnar”. My best guess is that there are remnants from old apps still residing in ~/Library but of course, there could be a lot of other explanations. In a desperate move I deleted all accounts in my Mail-app, rebooted and installed only my Apple account, installed the Mailplugin, but still no sign of the Mailbundle in Mail -> Prefs. I have also removed all non-apple menu-items (right hand) like Alfred, PopClip etc, rebooting, but still same negative result.

Will continue to poke around and see if I can find any suspicious candidates.

Best regards
Gunnar

I tried to access Apple Mail from “Import” sidebar today for the first time (Mac OS 10.15 + DT3.01). My inbox only have 737 mails and DT3 kept spinning, while everything in Apple Mail seemed slowing down dramatically. I tried access email from a mailbox with only 15 mails within DT3, it took 2 mins for me to see the emails. I tried to delete the bundles folder from library:mail:bundles, reinstall the Mail add-in, and restart the OS. I tried running the terminal command “defaults read com.apple.mail EnableBundles” within Terminal app and the system returns 1. I have enabled Full Disk Access for DT3.01

DT3 shows “not responding” after I re-installed the Mail add-in and accessed the INBOX in which only contains 735 mails.

FURTHER TEST 2: Rebuild the INBOX and reboot system. When the INBOX is selected in the “Import” sidebar, no mail is shown BUT this time there is a message in the log:

FURTHER TEST 3: Perhaps it’s just the malfunctioning of suddenly slowed-down internet. I found that the access of all local mailboxes (under “On My Mac”) are within reasonable time.

Thank you in advance.

Did you install & enable (!) the plugin for Apple Mail? According to the logs it’s unlikely that the plugin was used.

The issue was the results of the combination of two events (1) suddenly slowed-down internet connection (common in my area in rainy days) - thus very slow initial upload of mails to DT for the first time. This was leading to me (2) reinstalling the mail plug-in and had forgotten to enable the mail plug-in within the Apple Mail’s preference. (3) I did enabled the plug-in after the post, but still seeing very slow upload (due to reason (1) again). So, I PANIC.

The issue is resolved now and I confirm that it’s not DT3 or Mac OS 10.15 related. Thanks again.

Just an update and to close this topic from my side.
Rebuilt both my MacBook Air and iMac from scratch and the Mailbundla is now visible in Mail and working.
Best regards
Gunnar

Rebuilt both my MacBook Air and iMac from scratch

It’s a pain in the tuckus, but that’s actually what I would suggest people do with the mess that Catalina is right now: Erase and Install.
Not fun.
Not popular.
But given all the issues people are reporting - users and developers.

Actually, I (we) advocate not going to Catalina until *at least the first revision, potentially the second. See: https://www.devontechnologies.com/blog/20191014-catalina

Agree, but somehow, even realizing the selfdestruction possibility lurking in trying betas, we still do it. Remarkable!
Best regards
Gunnar