Apple Mail add-on failure

I have just had to Nuke and pave my iMac. On reinstalling DTPO, all working well, except mail App integration. I have installed the add on and the DTPO prefs confirm this I have also activated for DTPO in the Mail App prefs.

When I choose ‘Add to DevonThinkProOffice’ from mail.apps message menu, it doesn’t work and the log window gives error message Message import can’t connect to mail to get mail message data!

Even if I try to drag and drop the email from to DTPO inbox, I get the Log message Import of 1 messages failed.

Image 10-12-2018 at 15.09.jpg

Can you help me get it all working again please?

Try giving DEVONthink “Full Disk Access” permission in System Preferences > Security & Privacy. (Quit DEVONthink, change the setting, restart DEVONthink.)

PS: This was covered in our blog: … il-plugin/


That fixed it thanks.

BTW the Blog post says “The next update for DEVONthink Pro Office will be able to install the plugin without that you have to manually grant it full disk access. You’ll only need to enable the plugin manually should you need to reinstall it

As we are now on 2.11, I would advise that this seems not to have happened - at least in my experience.

Thanks for all the kind help

This problem still exists under Catalina. Well - sort of. I’ve managed to import a bunch of emails, yet just dragging and dropping the occasional one or two results in the helpful error message “Import of x messages failed” - would be nice to know exactly why? If I had more detail, it would save me the time of posting here!

BTW: I have given Devonthink 3 full disk access

Drag & drop requires neither full disk access nor the plugin. Where are the dragged messages located? E.g. in an IMAP/Gmail/iCloud/Exchange account?

I’m having similar problem: after updating to Catalina, drag-and-drop from into DT3 no longer works. The log window says “Import of 1 messages failed” but that’s not too useful, and the DT UI gives no other indication of failure mode. I followed the instructions here on the forum (e.g. in topic 48735) to clean-install the Mail plugin, and I’ve granted full disk access, to no avail.

The Mail menu item Mail > Add to DEVONthink 3 works, but I want to drag directly into the desired DT group.

This has become a serious impediment to my daily workflow.

Did you allow DEVONthink 3 to automate Mail, see System Preferences > Security > Automation?

Same problem.

  • Activated the plugin in Apple Mail
  • Updated the plugins
  • Reactivated the plugin in Apple Mail
  • Activated Full Disk Access for DevonTHINK
  • Activated Automation
  • Restarted booth tools

Drag&Drop into the Sorter wont work. Even into a folder at main screen wont work. I always got the Log-Message “import failed”.

Any other ideas?

Does it persist after rebooting the machine?
If so, try this…

To ensure proper the Apple Mail plugin is installed and enabled correctly, do this…

  1. Quit Mail.
  2. Quit DEVONthink 3.
  3. Enable Full disk access and all Automation requests for DEVONthink 3 in System Preferences > Security & Privacy > Privacy.
  4. In the Finder, hold the Option key and choose Go > Library.
  5. Go into the Mail/Bundles folder and delete the DEVONthink.mailbundle.
  6. Relaunch DEVONthink 3 and install the Mail plugin from DEVONthink 3 > Install Add-Ons.
  7. Relaunch Mail and enable the plugin via Apple Mail’s Preferences > General > Manage Plug-ins.

Same Error.

Followed all steps.

Step 7: Plugin was already activated. May I should reboot the machine before reinstall?

Nope, error stays the same. Is there any chance I could get more information why this import failed?

1 Like

The failure seems to be on my side of the application :slight_smile: On my iMac I drag & drop my mails like a pro. I only got problems on my macbook. I’ll investigate this case :slight_smile:

Drag and drop actually doesn’t require AppleScript or the Mail Plugin.

  • Does the issue occur with more than one email?
  • Is the email encrypted?

I tried single mails or whole conversations. All were not encrypted.

AppleScript is actually required internally but the Mail plugin isn’t in this case.

Yes, I have automation enables, and drag-and-drop from still has no effect. The DT item-list gets highlighted, but nothing is deposited.

What is reported in Window > Log?

I followed those steps but there is no option to import messages from Mail.
This used to work a few weeks ago.

Bad quality.

Please provide useful information if you’re going to report or discuss an issue. Thank you.