Apple Mail Plugin NOT working in Lion

I tried to reinstall to Plugin by going to DTPO - “Install Add-Ons” and check “Apple Mail Plugin”. However after Mail restarted, it still complain:

Mail has disabled the following plug-ins:

DEVONthink Mail Import Support

Contact the makers of these plug-ins for versions that are compatible with Mail 5.0 and Message 5.0.

I’m running DTPO 2.2 and Apple Mail Version 5.0 (1244.2/1244.3), i.e. Lion 10.7

Do you use any other plugins for Apple Mail or does it work after deleting ~/Library/Mail/Bundles?

Yes I do have other Mail plugin that is working in Lion:

When i tried to install the DTPO Mail plugin though it complained it is not compatible, and got put into /Users/lamp/Library/Mail/Bundles (Disabled) folder


I’m running Lion, and DTPO 2.2


I am sharing Peter’s experience, the mail plugin installed by DTPO (which has even the term “snow leopard” in its name) appears to be incompatible with Lion’s mail.

I dove into the DTPO application bundle and tried the various mail plugins manually, to no avail.


The DEVONthink Pro Office Mail plugin is compatible with Lion, and does work. I’ve been using it under Lion.

Those of you who have been using DT Pro Office for some time, moving from Tiger to Leopard, Snow Leopard and now Lion, will remember that with each OS X upgrade Mail has kicked out the Mail plugin.

The solution is to run the ‘Install Add-Ons’ routine once more. The Mail plugin will be installed and it will function.

Click on “DEVONthink Pro Office” in the menubar and choose “Install Add-Ons”.

Hi Bill – Thanks for your reply, I understand when you said DTPO 2.2 should “theoretically” work with Lion Mail. BUT please read my first post – which stated I did install Add-Ons numerous times without DTPO, but each time after Mail Quit and restart, the exact complain came of the program.

At this point, Is there some preferences file I have to remove? The 2.2 version was upgraded using the in-app Spackle framework, should I attempt to “reinstall”?


If, after a restart of Mail you get a message urging request of an update for the Mail plugin, click on ‘Cancel’. The plugin will function.

Dear Bill,

I’d like to hope I am not as much of an idiot as you might think :wink: I am glad it works for you, but unfortunately some of us are not so lucky.

Numerous times have I deleted the plugin, re-installed the plugin (the way you described, and manually by copying it out of the DTPO app bundle), restarted Mail, rebooted the machine, played around with the BundleCompatibilityVersion default (values 1 through 5, also deleted it), all to no avail. Every time I end up with the popup described by lamp.

I never saw any request for a plugin update, only said message stating that the plugin is not compatible (which only has an “Ok”-button, but no “Cancel”-button). The plugin will then be moved into a “Bundles (Disabled)” folder by Mail.

All the other plugins I have installed (Herald, MailActOn, MailFollowUp, MailRecent) work just fine.


Hi, Clemens. No imputation of idiocy implied. :slight_smile:

Perhaps there’s an important variable here. I have only the one Mail plugin, whereas you have several. That raises the possibility of interactions among the plugins. Maybe that’s why DTPO’s Mail plugin is working on my Mac, and not on yours.

As Voltaire’s Pangloss said, “This is the best of all possible worlds.” That’s another way of saying “Life is hard.” Apple’s new Lion makes a lot of code changes in the operating system. Those of us who dive into the “.0” version of a major OS release often have an interesting ride. Both Apple and application developers will discover surprises that couldn’t have been discovered in even the most elaborate beta testing. That’s why maintenance releases will come.

For the time being, my working databases are on a Mac running under Snow Leopard. I copy them onto a Mac running Lion and play with them there, getting experience with the new OS environment. Backups are highly recommended!

Thanks Bill - interesting thought. Unfortunately removing the other plugins does not help.

lamp, did you already file a bug report for this issue?


The Mail plug-in does work fine on my Lion machine and I am no expert so the chance is high that I am of no help for you.

But still a quick thought: Did you have the letterbox plug-in installed under Snow Leopard? It is redundant and most certainly defunct under Lion as the new Mail already has a three pane view mode. But maybe there are some leftovers from letterbox? Plus, I remember—I have been using Letterbox under Snow Leopard, but I have deinstalled it before going to 10.7—that Letterbox came with a plug-in manager. Maybe that one is still active and causing the conflict with den DEVONthink plug-in?

Just my two pence.

Sorry to hear you are having problems. I too have Lion, as well as some other plugins installed, such as Mail Act-on and Mail Tags but the mail plugin seems to be working fine for me.

Hopefully you can soon figure out what the problem is — As Suavito mentioned, possibly looking for the fragments of another plugin such as letterbox, wide mail, etc which may be lingering around.

Just my two cents. :slight_smile:

Lion 10.7
Devonthink Pro Office 2.2

OK just back from vacation.

No I don’t have Letterbox. I kept trying to install Apple Mail Plugin in Mail Add-on in Lion, (At first DTPO did not complain when it is installed in ~/Library/Mail/Bundles/DevonMailConduit-SnowLeopard.mailbundle is created). When is first launched, it kept saying the bundle is incompatible per my previous messages, and the Mail Plugin is moved to ~/Library/Mail/Bundles (Disabled). Doing the install again only created another folder, ~/Library/Mail/Bundles (Disabled 1)

I do have three other plugins, MailActOn, MailTags and OmniFocus plugin, all three are compatible, working, and updated for Lion. I tried moving them out of ~/Library/Mail/Bundles, and tried installing DTPO Mail plugin, it still does not work.

After wasting hours on this, I’m giving up. I’m also opening a bug count on this if the support team is not aware of this.


The update to 2.2.1 solved the incompatible plugin issue on OSX Lion Mail.


Actually the plugin of v2.2.1 is identical to the one of v2.2 :slight_smile:

Got the same problem.
Mail plugin don’t work in Lion with DTPO 2.3
The plugin is disabled and I haven’t found a new version of the plugin in the DTPO app bundle.

And I’m running Lion on a new Mac with DEVONthink Pro Office (current version) and the Mail plugin functions with no problem.

Did you allow Install Add-Ons to run after updating to version 2.3? And was the Mail plugin option checked in Install Add-Ons?

Yes, i tried to install it after the update but in fact I have never used the plugin and Idon’t I it has ever work in my Mail.
After the update, i check install mail plugin in Install Add-Ons and now each time Mail launch, he told me the message ever cited that this plugin wasn’t compatible.
But the script “Add message to DevonThink” works in the script menubar.

I am using Lion and have just upgraded to Devonthink Office Pro.
I have the same problem with the mail bundle.

It is installed at the right place but its name is: DEVONMailConduit-SnowLeopard.mailbundle
Deleting this and redo the bundle installation always comes to the same result.