Apple Mail Update

Noticing with the Apple Mail Update that the plug in no longer is working. Any work arounds available?




Close Mail
Remove the plugin from ~/Library/Mail/Bundles
Start DT
From DEVONthink > Install Add-Ons… install the plugin again
Start Mail

Please report again on your results

Just as in some previous OS X updates, Apple kicks out third party Mail plugins. But that does’t mean a plugin is incompatible. In fact, the DTPO Mail plugin is compatible.

With DTPO frontmost, click on the application name in the menubar and choose ‘Install Add-Ons’. Run it and the Mail plugin will be reinstalled.

I can confirm that I also had this problem and this did, indeed, correct the problem on my system (though for some reason I had to do it twice).

Tom S.


Unfortunately I am not so lucky - every time I reinstall the plugin, Mail will complain about incompatibility and move it again out of the bundles folder. I went through this a dozen times now.

I had this issue with the last OS X update, and it only got solved with the subsequent DevonThink update.

I guess I’ll have to wait …


Did you try korm’s recommendation to remove an existing plugin before another run of the Install Add-Ons procedure?

Do you perhaps have additional third-party plugins to Mail?

I have no problem with the DTPO Mail plugin functionality under OS X 10.7.2.


Thank you for your suggestions.

As you might recall, I went through the same problem before with the previous OS X update…

It does not make a difference whether other plugins are installed.
I tried many times.
All other plugins are working fine.

I just hope that the next DTPO update will magically resolve the issue, as it was the case last time.


But there’s been no change in the Mail plugin itself, in some time. :slight_smile:

There must be something about your computer that causes it to “think different” in an unfortunate way.

Hi Bill,

I don’t think change to the mail plugin is required for it to become incompatible with new versions of Apple Mail.

Could it be that the mail plugin declares, either implicitly or explicitly, a minimum and maximum for the version number of mail that it is compatible with? I don’t know how Apple Mail determines incompatibility, this could happen by using methods that now have been deprecated …


Try shutting down Mail. Renaming the Mail preference file (~/Library/Preferences/ [BUT don’t delete it!] then restarting Mail and reinstalling the DEVONthink plugin. This will tell you whether the fault might be in the preferences file. If that’s the case, then consider whether re-configuring Mail from “scratch” - thus establishing a new baseline for your Mail preferences file - is worth the effort. I don’t recommend attempting to edit the .plist yourself unless you really know what you’re doing.

I’ve found that the Mail preferences file lives on from generation to generation of OS X updates (from Tiger to Leopard to SL to Lion) and gathers lots of cruft along the way. I still have plugins defined in my Mail plist that I eliminated years ago.

Thanks for the suggestion, Korm.

I did as suggested, but to no avail. The plugin is still deemed incompatible.

Then, I opened the plugin’s plist file in Xcode and replaced all the compatibility info with that of a working plugin. Also no success.


Strange. Do you have the possibility of trying to install the plugin on another machine?

No comfort to you, but the plugin actually does work with Lion Mail out of the box :frowning:

True, but I believe the point that Bill was making is that the last update to DTPO could not have magically resolved the issue, as the plugin itself has remained unchanged.

As others have mentioned with their experience, the plugin is working fine with Lion for me.

Just FYI, the plugin works again after updating to …


Just for info: Plugin could be activated after 10.7.3 update again.