AppleScripts not working anymore - AppleScript system files damaged?!

Hi oh Knowledgeable Ones,

My problem: for some reason the supplied AppleScripts do not work on my system any more: E.g. NOTHING happens, activity shows nothing, nada. basic functionality behind it from within DTPO is working, though (like check and repair database).

Furthermore: I noticed the problem due to SpamSieve having stopped to accept to train for new spam messages. After some checking done Michael Tsai (Programmer of venerable SpamSieve) thought that the AppleScript system files could be damaged and suggested a re-install of Mac OS. I did that, actually moved up to Monterey!

Unfortunately, the problem persists in SpamSieve and when I checked in DTPO too.

Now what to do? I am very much open for suggestions, especially for doing something else than wipe my system and reinstall Mac OS from scratch.

Thank You!


Do you know how to use Script Editor? If so you could run one of the DT scripts from there, clicking on the rightmost symbol in the status (bottom bar) and choosing Replies or Messages to see what happens.


Hi Stephen, thanks for your replay. Unfortunately Script Editor seems to be affected too, I got a script to run from Michael Tsai, which just didn’t run at all.

I tried to open the DTPO scripts, but they just donot open, nothing is happening.

so I am back to square one: how to repair my system!


Welcome @rlfsoso

DTPO scripts

  • Are you referring to DEVONthink Pro Office 2.x?
    • If so, the 2.x line has been out of development for some time now. The OCR engine in DEVONthink Pro Office is also incompatible to macOS 10.15 Catalina and later. We strongly encourage you to upgrade to DEVONthink 3 sooner rather than later. Select ​DEVONthink Pro Office > Purchase ​to open our online store with upgrade options specific to your license.​ The Pro edition would be the natural successor to Pro Office.


oh that must be a misunderstanding. I am on the latest and greates DTPO 3.8 and Monterey. And somehow AppleScript seems to have stopped working. I noticed this with SpamSieve on BigSur, moved up to Monterey on suggestion of the developer of SpamSieve, but the problem persists and is noticeable in DTPO too. And it seems a system wide problem afaik, because trying to open the scripts via Sript Editor did not work as well. DTPO works fine, and stuff which would be called by the export daily backup script for example work without problems, but the script does not!

Suggestions welcome.

It has not. If you try to run a script in Script Editor, what do you see (turn on the log window by clicking on the list icon in the bottom right of the editor window).

How do you try to open them? Please try to be more specific in your problem description.

1 Like

That’s bold, but I admit to thinking the same thing. A simple script such as

set a to "check"
return a

run from Script Editor should provide sufficient proof one way or the other.

Hi Folks,

well I tried “open” (Menu, navigating to the proper folder) and nothing happens.
When creating a new script file, pasting in

set a to “check”
return a

I get the return “file could not be saved automatically”

When trying to “save as” (with a new name instead of “new file” –- I am on a German system) no file ist created.

And when hitting “run”, I get no result down in the results window part.

So yes, something is NIT working and it looks like AppleScript to me. And Script Editor too (at least not properly).


Does script editor have full disk access?

For what it’s worth, Script Editor does not have FDA on my mac. But it’s certainly a step I would try in the OPs case.

Where are you trying to save to?

That might suggest a problem accessing iCloud Drive; it may be worth logging out your AppleID and logging back in (which in my experience is about as appealing as reinstalling the OS from scratch…)

Are you running “anti-virus” or anti-any-other-threat software which might be inhibiting execution of scripts?

Do you see the same issue on a new macOS user account on the machine?

checking tomorrow. Thanks! R.

No problem. Let us know at your leisure and convenience.

Hi Bluefrog,

that put the finger on it: the problem disappears on a new, fresh account. Duh!

Now what to do. Obviously I need to migrate (all) my stuff to a new fresh user account. Uff.-

What is the best procedure for this? I wonder what happens if I use migration assistant…

Procedure (?):

  1. create backup (1, 2, many, including time machine)
  2. create new user account (admin), start with apple id, icloud etc.
  3. erase old account
    4a) use migration assistant (!?) to move the rest or
    4b) just move data manually (?), restart every program, register/ put in license etc.

I am open for the best way/suggestion, especially as 4b is going to be a pain.