Application Error - An error has occurred. The Application m

I can´t use the app. Every time I want to make a new note I got this error: Application Error - An error has occurred. The Application must exit.

Has anyone else this problems?

My System: Iphone 3g and 3.1.2

I’m getting this error quite often too. I’m using DTTG on my iPad and it seems to happen after I perform a search and hit the ‘back’ button to navigate back to my folder hierarchy.

You should definitely use the Bug Report link to submit this.

Same problem here. Every time I try to create a Text note, it get the application error message and the app crashes.

Hopefully this will be fixed soon (no delays in the Review process), and I will be able to use the application I have waited so long to.

fyi I have an iPhone with 3.1.3.


There may be something wrong with your installation. Have you tried a different database; or failing that, resetting your app (Settings app>DEVONthink>Reset); or if all else fails, reinstalling the app?

I have tried both of the suggested actions (Reset and also Reinstall), and non worked. Still crashing.

Any additional suggestions to get my $15 worth app working, will be highly appreciated.


Can anyone with a device running iPhone OS 3.1.3 reproduce this reliably?

eric, let me know how can I help you/reproduce it, with the info you need and I will be glad to do so.


I too am getting the Application Error following a search. I enter a search term, the results are displayed and I can view them without a problem. However, as soon as I select the home or back buttons I get the message “An error has occurred. The application must exit”. It duly exits, but returns to the same place when launched again! To break the cycle, I have to enter in the search box something that is sure to have no hits (eg a random jumble of letters) , and press search. Having found nothing, DTTG then allows me to return to the home screen. Only a null list of results seems to break the cycle.
I am using an iPad with 10.6.4 on the Mac.

iPhone 3.1.3. and the same bug ! :wink: Sorry Eric ! :cry:

Ditto the bug, in many places. Search. Add an image. Back button. Go will crash, then when I reopen what I was trying to do is there, most of the time. I’m sure Eric and the gang are on this one. :slight_smile:

I’ll test it when time permits.

With iOS 4.1, it happened the last 5 times I tried a search, show search results, cancel, go back, create item in global inbox or new text in some db… Sometimes the Application Error would happen even before trying to create an item, other times there were weird things going on I’d have to try again to mention. Once it seemed like there was even a left side toolbar that started to swipe into view and then disappeared (don’t think I have anything from cydia that does that).


Same bug here when I try to go back after a search
iPodtouch 1st Gen iOS 3.1.3

Same problem on mine also. When I try to go back after a search, I get an plication error and it closes down.

Regards, Tim

Same problem here on an Ipod 1st Generation. Cannot create a new text note. As soon as the Editor starts, the same error message appears.
Thats really not the way I expected the program to work. And, yes, I tried to reset several times and still cannot add a text note.

This is exactly what I am experiencing too. I found it quite difficult to get it to break out the application error loop. I never thought of searching for a “null string value”.

I’d like to see this one fixed for v1.01… soonish :slight_smile:

We are (as noted on this thread) seeing a number of crashes related to search. We apologize for the issue you are finding and looking to find the core issue(s) as quickly as possible. Thank you for your patience and we will post more information as we determine the exact nature of the problem.

reading the posts, there is not only the problem with search.
The reproducible errors are:
It’s not possible to write a text note. As soon as the Editor starts, the error message “An error has occurred. The application must exit” appears, the app crashes.
Even viewing a simple (synced) textfile let the app crash when I touch the screen - that’s information at my fingertips only when I hold my iPod touch 1Gen very carefully… :confused:
That means, that a major function is fully missing: it is neither possible to edit a textfile (I mean .txt) nor to create one.
Very bad - especially for a company like DEVON! A high-priced app that doesn’t work…

To the user that is experiencing crashes writing text notes, please file a bug report. We understand your frustration but this is the first report of any issues with text editing, and we need details to solve your problem (iOS version, perhaps a more complete set of steps to recreate the problem).

As for the search issue, note that we are working on making Search more robust for the next release, at least to insure that crashes no longer occur. That said, please note that it is iOS that keeps taking you back to the Search screen - that is out of our control. The OS saves state when an app ‘exits’ on iOS 4.x, even when that exit is a crash. So you invariably end up back in the same place.

To mikekppp:
Sorry, but you are wrong, it isn’t the first report! Please read Malm, ColinMcNairney, orlandold and samuel in their posts above in this topic!
Read it and you’ll see, that they have the same, I think major problem!
I did a reset in the settings, started DTTG again and the problem persists: every time I try create a text note, the app crashes with “An error has occurred. The application must exit”. After restarting, it isn’t possible to delete the 0 Byte files.
It isn’t even possible to create a group or an entry from the “Album” (in german) - program crashes.
These were the steps to reproduce the problem.
I use a iPod touch 1G with iOS 3.1.3. (Several Gigabytes of memory are free)
Don’t you test your program before releasing it?

O.K. and in the next few hours I’ll do a full new install.