Apps that (really) work with DTTGs Document Provider Feature


I want to collect Apps that use the Document Provider Feature in the right way (File stays in DTTG and changes are edited in the original document, no copies).

I have found a few Apps that handle this well, maybe you can name some other apps that do also a good job with the document provider feature. (At this Point DTTG is so essential for me that I would gladly change to apps that do File handling well.)

File stays in DTTG and changes are edited in the original File
PDF Expert 5 (PDF View & Annotation) :smiley:
Word (Wordprocessor) :smiley:
Ulysses (Markdown Editor) :smiley:

Document Provider but File gets exported
GoodNotes (Notetaking & PDF Annotation) :frowning:
LiquidText (PDF Annotation) :frowning:

I am especially interested in Notetaking/scribbling Apps that work with DTTG, maybe you have some input on other good integrated apps.

We seem to want to proliferate threads on this topic :unamused:

Anyway, using the OP’s iconology – for Markdown-aware apps that work with document provider / DTTG:

Textastic :smiley:
Byword :smiley:

Notes Writer+ :frowning:
Scrivener :frowning: (but that’s expected and not a bad thing since Scrivener depends on its own sync process :stuck_out_tongue: )

and there’s 1Writer, which works with the document picker as :smiley: but doesn’t seem to want to recognize .markdown or .md files in DTTG as editable markdown, and will not open them – so :smiling_imp:

Not seeing that problem with 1Writer myself, with either .markdown or .md extension, on iPad or iPhone. What app are you using to create the documents?

DEVONthink Pro Office 2.9.10 (sync to DTTG).

Just tested the same process here, opens fine in 1Writer 2.5.2. I do only sync via Bonjour, although I would be surprised if the sync process had any effect.

Yeah, sync wouldn’t make a difference. FWIW, I use WebDAV. Just uninstalled and re-installed 1Writer and it does not recognize markdown files in the DTTG document picker as editable. BUT it will open and edit plain text files.

Sometimes on macOS an app can mess with the default app assignments for file types and screw up other apps. I wonder if that’s possible on iOS and if some rogue app did something that confuses 1Writer.

Oh, well.


thanks for starting the collection - very interesting!

I mainly want to find out about editing of markdown files located in DTTG. Can you kindly walk me through the editing and saving of such a file in Ulysses? I tried but failed - so this would be a great help for me!

Many thanks in advance,


Open Ulysses on your iPad (iPhone is similar)
Open the Library
Open External Files
Press the External Files panel (the middle pane on the screen)
That pane will slide over to the left side of the screen
Press the icon at the bottom of the External Files panel that looks like a cloud on top of a document
The document picker will open
Select DEVONthink
Navigate your databases in the document picker to choose the thing you want to edit
The document will open
Edit it

That cloud-on-document icon that opens the document picker is also available on the edit panel (right 2/3 of the screen at this point) and you can select a document there.

Remember – generally, when you are using document provider in some app to choose a document from your database, you don’t need to open DEVONthink except to sync changes at some point.

And if External Files (in step 3) don’t exist, tap “Manage” in the bottom of the left panel and then tap “Enable External Files”. After tapping “Done” in upper right of the left panel, you are back where you began and External Files (step 3) should now be displayed.

You can also send files from the iCloud and Dropbox sections of Library to DTTG databases

Open the Library
Select the iCloud or the Dropbox section of Library
Select a Group or Sheet
If one Sheet is Selected
Press the document on the right side
Press the Export icon (box with upward pointing arrow)
Press the three-dot icon
Select Upload
Navigate through the document picker to DTTG and your database / group

In step four, if you want to select multiple sheets, press the first sheet in the middle of three panels
The middle panel will slide over to the left
Press Select at the bottom of that panel
Choose the sheets to export
Press Export at the bottom of that panel
The preview will open
Continue with pressing the three-dot icon as above

In either case, before you send a sheet or a compiled set of multiple sheets you can press the type of file to export in the menu of the menu and chose HTML, or text, or PDF, or whatever – and send that to DTTG.

When finished, open DTTG and sync - or read – or dance a jig and sing a ditty

Thanks, korm, for your help – much appreciated!

Now the bad news: I did as you said; it worked - but DTTG froze hard as an effect. Even restarting the iPad was of no use. It remains frozen, no interaction possible, and returns to the iPad desktop after some 30 seconds or so.

Guess I’ll have to report this to the troubleshooting part of the forum :frowning:

Thanks again!


Have you tried to soft-reset, or did you simply restart the iPad? Doesn’t always work, but does the trick more-often-than-not.

Soft-reset = holding down power/off button and home button together for +/- 10 seconds, until the Apple logo appears on the screen.

Me too? I worked out these instructions on an iPad Pro and checked them out on an iPhone 6. Both on iOS 10.2.1. Both instances of DTTG froze, regardless of what I did – hard reboot, etc. It occurred to to me that maybe Ulysses was complicit. So when made sure there were no DEVONthink-stored documents open in Ulysses, double-clicked the home button and flicked Ulysses off the screen to shut it down. DTTG no longer froze.

So there’s a bug in document provider, or Ulysses (good luck getting them to pay attention to any user issues), or DTTG.

Andreas, if you try this maneuver with shutting down Ulysses, please let us know if it also worked for you.

Thanks, Cassady, for the hint - I didn’t know this version of reset yet.

Unfortunately, it made no difference; DTTG still hangs and is unresponsive.

Version 2.1.2 (in the review queue) should fix this issue.

It’s a shame that editorial app dose t work with DP

@renatovanzella: Talk to them about it.

It does. But Editorial does not support document provided. However, search the forum. I posted an explanation of how to use Editorial and DTTG in split view very easily.

already did that!