Assigning a default database

I am confounded by this one.

I have two databases: Work and Personal.

I have assigned my Work database as the default (in the properties of the database itself and also through DevonThink’s main preferences.

Despite this, DevonThink continues to open up on the Personal Database.

What am I missing?

see the documentation, page 74:

Choose whether you would like DEVONthink Pro Office to open a fresh main window on startup, open all windows that were open when you quit DEVONthink Pro Office the last time, or do nothing.
If “Open all windows that were open on quit” is selected, DEVONthink Pro Office also opens all databases that were open on quit.

This is in >Preferences > General

I think your expectation is accurate - to not open the database you set as default in Preferences or in Database Properties is inconsistent with the preference. Seems like a bug.

(The Startup setting mentioned in another posting has nothing to do with modifying which database gets the focus on startup - the setting only affects the set of databases that is opened.)

Thanks Korm,

I can attest that the suggestion by Berndm is not the solution as I rarely open my personal database and always have my work database open and yet it still returns to personal on start up.

Thanks for the contributions, I guess we will wait for an update.

@Tobruk, do you have a workspace defined? (Go > Workspaces) Just on the off chance it might be interfering with your startup, you could try deleting existing workspaces, if any. The Workspace > Edit menu is where deletion is done. Another think to try is to close your personal database, so that work is the only one open, then quit and restart DEVONthink a couple times. Or delete (or merely rename) the DEVONthink preference file in ~/Library/Preferences – something there might be mis-behaving. Just suggestions to get the bug to not be buggy :cry:

It wasn’t clear to me from your first post, that instead of the default db the other one get’s opened, I assumed you were confused that both and not only the default one will be opened.

However, what I quoted from the documentation reliably works here. If I uncheck that option, only the default database will be opened on startup, otherwise all databases that were opened before quit are reopened. I see no bug here.


Your last suggestion–rename and close–worked.