Assigning keystrokes to menu items in DTP?

Is there a way to assign keystrokes to a Menu item in DTP? I wuld like to assign a keystroke specifically to an item in the Data>Open With menu. Alternaively, and probably preferably, I would like to change the default PDF reader from Preview to Skim but I do not think that this is possible…unless someone knows differently?


Apart from the already given shortcut in that menu for opening items with their default application, this should not be possible, as the list of offered alternative applications is changing depending on the kind of the file.

DEVONthink Pro (Office) respects the systems settings. So if you would set Skim as your default PDF reader in OSX (CMD + i on a PDF in the Finder > Open with = Skim > Change all), DEVONthink Pro will open PDFs with Skim from there on. (You can revert this any time.)

Another option, that I could imagine for LaunchBar-users like me, would be to have a script, that opens the actual chosen item in DEVONthink Pro with Skim. That would be two shortcuts.

Use System Preferences > Keyboard > Keyboard Shortcuts > Application Shortcuts. Create a shortcut group for DEVONthink, and add a shortcut for any application that might appear in an Open With… submenu. (Apple’s instructions for Lion appear here, and haven’t changed since Lion was published.)

For example, I created a shortcut for PDFpenPro this way. As long as the app name is spelled correctly, then whenever that application appears in the Open With… submenu (i.e., a PDF is selected), then the PDFpenProshortcut will be active.

Also, the default Open With… application (the one at the top of the Open With … list) for any document type is always given a Shift-Command-O shortcut. So, if you use Finder to set Skim as your default PDF application, then in DEVONthink it will automatically open with Shift-Command-O when a PDF is selected.

Oh, I didn’t know that, I thought this would only apply to fixed menu entries. Thank you!

Excellent, thanks for this.

Sorry for bumping this, but I’m having trouble writing out the command properly in the Keyboard Shortcut Preferences to make my shortcut work.

I want to open RTF files with CleanWriterPro (that’s exactly how it’s spelled in the menu). So I typed: Open With CleanWriterPro in the command box, but it didn’t work. If you or anyone can help me out I’d greatly appreciate it!

You only need to add ‘CleanWriterPro’ to the command box.

You’re awesome!! Thank you very much!