automatic synchronization workflow

Hello, I am currently trying to used Devonthink Pro office solely through indexing certain files and creating a sort of searchable web server. I tried to create an automator workflow that everyday monitors what is located inside a specific folder and synchronize it with the database. However, it seems like there is no way of doing such a thing. The only option i see in automator is ‘synchronize records’ which doesn’t seem to help. A little help would be appreciated, especially since i’m not too good with applescript. Thanks.

Using Automator there is a way but it uses the “Filter Items” action, you can use it to give a list of files and return only the ones that aren’t in the database. Then you can index these.

but i’m wondering what the ‘index’ command is in automator for devonthink since i can’t actually see one called that.

How about the “Add items to Current Group” action? There you can choose to either import or index the files. I would strongly recommend you go through some of the example workflows that we ship and document in the online help. The examples are found in the distribution image that you downloaded from our website. It will make you feel a lot more confident with these actions.

Also don’t forget that each of our actions has a detailed description, it will display when you click on them in the action browser of Automator.

I made such a workflow and it worked. Now with the update to Leopard and Devonthink 1.5, it doesn’t work.

The workflow is:

  • Run Shell script to search for pdf, html,…
  • Open database
  • Set current Group
  • Filter items (option: missing items)
  • Add items to Current Group (option: index)

The workflow gives an error in the last action, but the result for the Filter items is empty (and I added files so the result shouldn’t be empty).

The error i get is:

Anybody an idea why this fails now and not in the past?



It doesn’t fail, there are just no items to add. In the Leopard update this has become an error check has become more strict. In Tiger this wasn’t flagged as an error.

Well that is the problem. I added new items and the result of filter missing items shouldn’t be empty. (if I reverse it and ask to filter the existing items, the result is still empty)


You are correct, I did some testing and it seems that the application doesn’t return the correct result. I need to consult with Christian who’s on holidays right now but if it turns out to be a bug, it will be fixed in the next maintenance release.



do you have an update on this issue?


Like I wrote before, it will be fixed in the next maintenance release.


The Devonthink update didn’t resolved this issue. I still get the same error. Is there something I can do, because my Devonthink database is getting out of date and useless :frowning:


Send your workflow and as much other info as you can give us (maybe a small sample database with a sample folder structure) to With my tests it seemed to resolve your issue.