Automatic syncing with 5 devices

Hopefully a quick question.

I’m using DT3 on 2 devices and DTTG2 on 3 devices.

I have sync stores on iCloud for some databases. Other databases I sync using the Bonjour option.

At the moment I have all devices set to sync manually and I perform a sync on each device multiple times per week. As you can image, this is rather tedious and time consuming.

I would like to change that so that all devices sync automatically.

I’ve never tried automatic syncing so I’m a bit nervous about it.

Are there any known issues doing this with 5 devices?


Not at all I was aware of.

I have one third Mac than you and had no issues. More complicated even: 1 of 6 devices are out of main network always and my iPhone go out/in network. I use one WebDAV sync store.

Depending on size of changed data, so and then you will find your things haven’t fully synched because iOS background limit time (or not received correspondent push notification), but once activated, they will finish sync.

works for me. just give it the time it needs.

Thanks for the replies. I’m going to turn on automatic sync on 3 of my devices and test that for a week or so.

Remember that DEVONthink must be running on the device to sync … I say that as when I launch DEVONthink ToGo on my iPhone it is out of date until the sync continues. So, sometimes I just turn it on while doing something else to be ready.

Thanks rmschne. I was hoping for some sort of background syncing process that would take care of it on iOS, but I can make sure to run DTTG periodically.

Totally agree. DTTG on iOS needs to be for a while in the foreground to sync everything. I leave it once a week on the charger over night and hope that everything’s synced then - and most often it is. :smile:

Do you have to change the settings to stop the phone going to sleep?

I notice that DTG does have a background refresh option though - my understanding is that it does attempt to sync in the background but Apple doesn’t give it enough CPU to get much done that way. Is that correct?

Seems to be the case. All the background stuff is controlled by IOS (Apple) far as I know.

The only way I know to stop phone from “going to sleep” (not sure it ever does, actually), is to put the display time-out to “never” and then it looks like it’s working.

Gotta always remember the iPhone is not yet a real computer.

Gotcha. Just to make sure we are talking about the same thing, is it:

Settings/Display & Brightness/Auto-Lock: Never

Yes. Seems to keep it “alive”.

That’s what I do too.