backups "corrupt", become empty on "restore"

Regrettably I have not kept external copies of my backups in DT Pro and now I am in a pickle. Upon opening the app this morning I was informed that the datafile had an error and I should verify it; that yielded a report that there were thousands of errors, and the database essentially vanished. I read the help and tried to restore from the most recent of the 3 backups I keep. It had the same problem and went from 455 MB to 0. I tried the next most recent back up. Same result. I now (slow learner) have made a copy of the one remaining backup and searched this forum for advice. I found one from Christian Grunenberg (2007) which said

"Please select the database package in the Finder, choose “Show Package Contents” in the contextual menu and copy (!) one of the Backup folders to the desktop. Copy (!) the Files folder into the copied (!) Backup folder and finally append the extension “.dtBase” to the copied folder’s name.

You should be able to open this backup now by double clicking on it - does this procedure work for any of the Backup folders?"

When I look at the Package contents, however, the contents of the “Files” folder are far smaller than the size of my backup and are not up to date; the folder says it was last updated in February of this year and the files themselves show dates of 2006 and 2007. My Prefs were set to backup once every day and keep 3 backups (obviously in light of current experience I would make some changes!).

So putting the contents of the “files” folder into a copied “backup” folder and changing the file extension, as advised in C Grunenberg’s post, is not going to restore my database. I have already lost some data, everything from the last two days of active use (there were some days in the past week where I did not alter DTP’s database) but surely there is a way to get this one remaining backup to work? After making 2 copies I tried opening one of the backup copies by double-clicking on it; this time when it told me it had a major file error, instead of asking it to rebuild it I chose “Ignore” and the result was that while DTPro opened a database that was empty, after I quit I found that the database copy was still at 455 MB.

Another question: I thought I had DTP set to check for updates and let me know but I see that I am running 1.3 and the latest is 1.5.1. Is there any chance that upgrading might fix my problem?

Thanks to all who have read this far and I look forward to your analysis and suggestions.

[As for cause, all I can think of is that someone else used my computer yesterday while we were trying to figure out a problem with our Airport Extreme Base Station and possibly did an improper shutdown.]


Hi, Cynthia. It’s a good idea to check for updates once in a while, especially if you have updated your operating system.

It’s worth a try to install the current version 1.5.1. Send us an email to Support (Help > Support) if that doesn’t work.

Another thing I highly recommend is using Scripts > Export > Backup Archive once in a while. When I’ve made significant changes to a database, at break time I’ll invoke Backup Archive. When I return from break the database has been verified, optimized and has current internal and external backups. That external backup is the smallest possible compressed and dated archive of the database. It’s a good idea to store that file on an external drive or DVD disc.

In all the years I’ve used Macs I’ve only had one hard drive die. But I had backups of my DT Pro databases on an external drive. I also make it a point to copy backup archives of my databases to DVD discs once in a while and keep those at my bank. And I use Leopard’s Time Machine.

My databases are worth more to me than the computers that host them. Bad things could happen to those computers. They might fail, or be stolen. My house might burn. Unlikely as those things might be, they do happen to people. Making backups, including off-site storage, is like buying insurance on my house and vehicles, which I also do.

Over the past three years I’ve had to resort to a database backup only once. No problem, as I had a current backup.

My favorite Cajun humorist was Justin Wilson, who was also a safety engineer. His motto was “Belt and Suspenders” when he gave safety lectures. Never, while he was giving lectures, did his pants fall down. He was a wise man, and funny, too.

Thanks, BIll. I used to have the same policy of “belt and suspenders” for my macs (starting with OS 5 I think), offsite backups, all data backed up regularly to disks, but I guess the stability of OS 10 and apps like those from Devon Tech have lulled me into inattention. No more, believe me.

I will be sending Support an email because DTP 1.5.1 has the same problem with a copy of my lone remaining backup. First finds 1 major error, then after verifying, 19272 errors leading to an empty db if I continue the process.