Beta 2 markdown display: Black text on black background

I just updated to beta 2 and found that all of my markdown notes are unreadable with black text on a black background. I was able to partially fix this by adding:

* {
	background-color: white;

to my DT css file so I can at least read my notes but with this override there are still black bars through the notes in the blank spaces and some other issues.

Is there another setting somewhere to fix this or is this a beta 2 bug? All of my markdown looked fine in ver 2 and beta 1.


Do you use your own Markdown stylesheet (see Preferences > Markdown) or is the stylesheet embedded into the document? Over here everything seems to look as expected without any stylesheets.

Welcome @scc

If the options Criss described aren’t being used, you may also want to consider trashing the application preferences.

  1. Quit DEVONthink.
  2. Open /Applications/Utilities/ and paste: defaults delete com.devon-technologies.think3 and press Return.
  3. Type: exit , press Return and quit Terminal.
  4. Relaunch DEVONthink.

Thanks @BLUEFROG & @cgrunenberg . I use my own stylesheet.
I see what happened: the background flip-flopped in beta2 from white to black for dark mode so my own css font colors caused things to disappear. Removing the css file fixes this and so does changing all the font colors in custom css to white.
Viewing all my notes as white on black will take some getting used to. I prefer reading notes on white background (like rtf and formatted still do). I’m curious if others feel the same.

You’re welcome!

So I changed my css to use white text and my markdown previews looked good and I was happy for a few minutes, but then I realized that I can’t read my web archives because they are now white font on white background.
I think that having any custom css now breaks things since markdown is black background and web archives are white background and they both use the same css file.

The stylesheet for webarchives should be specified in Preferences > Web.
The stylesheet for Markdown should be specified in Preferences > Media.

PS: Markdown source is just plain text, so you should be able to merely swap the background and text colors in Preferences > Editing, like so…

Ah, I never knew there were two places for stylesheets–I’ve always just used the Web stylesheet for my markdown.

It seems that having any css in the Media preference makes everything white in markdown previews for some reason. Also, the background/text settings in the Editing preference don’t seem to do anything with markdown previews, even when there is no custom stylesheet specified.

I just scrapped my custom css entirely and I can read both my notes and my web archives which is the most important thing.

Also, the background/text settings in the Editing preference don’t seem to do anything with markdown previews,

Correct, as the preview is controlled by styling, internally in DEVONthink or via typical styping methods.