Blank PDF with Clip to DEVONthink Extension

I saw that someone else posted this problem recently, but the solution for them was to update the Clip to DEVONthink extension. I have tried this and it hasn’t worked, so I’m posting a new topic.

I have used the Clip to DEVONthink extension in Safari and Firefox quite a lot recently, and it has always worked well up until today. Today I am trying to clip a page, and it only generates a one-page blank PDF. This happens whether I do it in Safari, Firefox, or Chrome.

The page I am trying to clip is this one: … -your-rice

I am using the paginated PDF option with clutter-free layout. The PDF actually does generate ok if I uncheck the clutter-free option, but the PDF it generates is not nearly as nice, so I would really like to get this feature working properly.

I have already tried uninstalling and reinstalling the extension in Firefox and that did not help.

If anyone has any advice on how to fix this it would be greatly appreciated!

Not every web page is capable of being clipped (clutter-free or not). The content isn’t in the underlying HTML for this page, nor does it appear to be in an “article”. Capturing it without clutter-free or as a PDF would be the best option for this site.

Thanks for the reply. I do think there is something else going on though. The main reason is that I have clipped dozens of articles from that same site, even as recently as two days ago (I started having this problem yesterday), and they have all worked perfectly using the Paginated PDF with Clutter-Free Layout Option.

Also, I just tested it with several other pages and all of them gave me the same result: a one-page, blank PDF. It seems unlikely that they would all share the same problem. These are the pages I tested. … kward.html … up-8167587 … esia-fails

I’m happy to test other sites if needed.

Is the browser extension up to date?
Does this persist after rebooting the machine?

Yes, I have already restarted my computer, and I have already uninstalled and reinstalled the extension in both Safari and Firefox, and the issue still persists in both browsers.