Bonjour challenges

Having sync issues with Bonjour. Running Big Sur 11.1, iOS 14.4 and iPadOS 14.4, DT Pro 3.6.2, DTTG 3.0.1.

Enabled Bonjour on the Mac (Preferences → Sync → Bonjour Options, checked “Enable incoming connections” and “Open databases automatically”, entered a password, left “Port” blank although DT seems to have auto-filled 56846).

Went to the iPad. DTTG Settings → Locations doesn’t show the Mac - just the 5 defaults.

Went to the iPhone to troubleshoot. DTTG Settings → Locations, the Mac shows up. Enabled it, synced some small databases to test, everything seems to work fine.

Rebooted the iPad. The Mac showed up now in the sync list, so I attempted to add it as a location. I got the error “Attempt to connect to host timed out (AsyncSocketErrorDomain 2)”. It never asked for a password.

Went back to the iPhone. When I go in to Settings → Locations, under my Mac it shows “Local Network (Offline)”.

Back to the iPad. Deleted and reinstalled DTTG 3. Mac in the sync list, attempted to add the location, got the Async error again. Still never asked for a password.

iPhone hasn’t budged from “Local Network (Offline)”.

Everything is on the same wi-fi network, and that wi-fi network otherwise seems to be working. No issues with browsing and such on the iPad, iPhone, Mac, etc. DEVONthink on the Mac is open with all the databases open. The Mac’s built-in firewall is disabled.

It feels like something really weird is going on with Bonjour. Any ideas what might be going on?

Try quitting and relaunching DEVONthink.

Also, are you using a VPN on the problematic device? Bonjour will not work over VPN.

Now I feel silly. A reboot of everything, basically simultaneously, ultimately solved the problem. It’s weird that it was mainly the iPad though initially.

Thanks for the help!

BTW, am I understanding correctly that Bonjour syncing is basically the “gold standard” for reliability with DT (as much as a “gold standard” for protocols beyond your control can exist :smiley: )?

You’re welcome!

We all use Bonjour in-house and yes, it’s generally a reliable, very fast, and very private method of syncing.

2 Likes

I have literally tried absolutely everything to get Bonjour to work. I have a 16-inch MBP (2019) running Monterey 12.4, DEVONthnk 3.8.3, and DTG 3.5 (17211) on my iPhone 13 running iOS 15.5. I’ve completely turned off my Mac’s firewall. I’ve uninstalled Little Snitch. There are no VPNs running on either device. Both the MBP and the iPhone are on the same wireless network. I don’t know how much clearer and insecure I can make these two machines. I enabled Bonjour on DT on the MBP, leaving the port blank and setting a password. I’ve deleted and reinstalled DTG. I’ve rebooted by devices, at the same time. I’ve done absolutely everything that I can find has been suggested to fix this issue … and yet, I still get “Attempt to connect to host timed out (AsyncSocketErrorDomain 2).” It’s maddening. I don’t know what else to try. Please help.

Welcome @jwalthour

Is Bonjour disabled in DEVONthink To Go?

Thanks for replying, BlueFrog. Yep. I tried it both ways. When I read your posting about 1 server, many clients, I disabled it in DTG and tried with just my MBP being the server. Still no luck.

re-look at the WiFi network settings on both iPhone and MacBook. Should be on the same private IP address range, e.g. 192.168.x.x or other, and check subnet mask is exactly the same on both.

Edit: Also, confirm connectivity by doing a “ping” from the Macbook to the IP of the iPhone in a macOS Terminal.

1 Like

Quit and relaunch DEVONthink and DEVONthink To Go.