Bonjour sync not showing up?


I have a Macbook Air and Macbook Pro. My Macbook Air has my DEVONthink databases, and I want to sync them to my Macbook Pro via Bonjour. On my Macbook Air, I went to Preferences → Sync, and enabled incoming connections for Bonjour. On my Macbook Pro, when I go to Preferences → Sync, my Macbook Air does not show up, and there’s no way to manually add a Bonjour connection even if I know the IP address and port number.

How can I fix this?



As an initial step(s), re-boot both machine and ensure they are both on the local network, then on your MacBook Pro ensure Bonjour’s “allow incoming connections” is not checked “on”. Only one device, acting as a so-called “server” in a network should have this setting “on”. DEVONthink on that machine needs to be running to allow connections.

For me, on the equivalent of you MacBook Pro, my “server” shows up in the list of “Locations”.

I found out why. It looks like Bonjour sync only shows up when the Macbook Pro is connected via Wi-Fi, even though the ethernet connection connects it to the same network. My Macbook Air is connected via Wi-Fi for context. Why is that? Is DEVONthink only looking for Bonjour connections via Wi-Fi somehow? I would prefer using the Ethernet connection if possible. Thanks!

I’m running into another issue with sync now. For some reason DEVONthink is using up all the space on my Macbook Pro. It’s constantly syncing, and thus probably making duplicates? My entire database is only 22 GB on my Macbook Air, but on my Macbook Pro it just keeps getting bigger and bigger until it made my Macbook run out of space today. I found that Library/Application Support/DEVONthink 3 took up more than 230 GB of space!

Hold the Option key and choose Help > Report bug to start a support ticket.

1 Like

I found a solution around the problem: I copied the entire .dtSparse file from my Macbook Air to my Macbook Pro by accessing the MBP’s folders in Network in Finder. Then I set up the MBP’s DEVONthink to start syncing with the MBA. I still don’t understand why Bonjour sync doesn’t show up on Ethernet and only on Wi-Fi though…

For context, by Ethernet connection I mean via a Thunderbolt 2 <-> Ethernet adapter. When I run ifconfig Wi-Fi shows up as en0, whereas the Thunderbolt->Ethernet connection shows up as en4. Could that have something to do with why Bonjour sync doesn’t work on Ethernet?

I’ve forgotten more than I ever learned about TCP/IP networking … but I do recall that Apple’s Bonjour only works between computers on the same subnet. Check that your Ethernet network settings is the same as for your WiFi (which works) on all devices. If different, make same and see what happens.

Yes they are on the same subnet.

Interesting. First, full disclosure. I have completely forgotten what subnetting is and frankly trying to avoid re-learning. But I did a google search on “bonjour not working on ethernet” and there are some hits with advice from probably credible sources in the Apple-world. I note top hits are a decade old so don’t know significance of that.

So you have two IP interfaces configured on the same machine. Only one can be the default. If that’s the WIFI, Ethernet will not be used, I suppose. And vice versa.

If they’re on the same subnet, how would you tell the host which traffic goes where?

But if only one active, and both configured on same subnet, is there a problem? I think the OP @egao is saying that with WiFi “off” and Ethernet “On” Apple’s Bonjour not working.

If only one is active, that should be ok.

And running Bonjour over cable should work, I think. Since Bonjour was probably introduced before Wi-Fi became ubiquitous.

that’s what I think also as that’s how I do it between the two macs 1/2 the time (as I tend to turn off WiFi on MacBook when at desk … why? dunno. Just do. I tend to get better performance wire vs. the WiFi).

Wifi has a bigger overhead than wired Ethernet due to the wireless network layer (one part of that being encryption).

1 Like

I have two Macs on Ethernet only, each connected with a USB-C to Ethernet adapter.
They’re on en5 and the server is seen, client connects, and syncs happen with no issue at all.

Do you have WiFi still on?

Frankly, my strong hunch is that the issue @egao has is with the network software settings (or hardware?) and not anything DEVONthink is defeating or affecting.

1 Like