Bringing Word documents into DT

I have just finished reading an article from the "Applelinks" site about the inability to use Virtual PC on the new G5 computers.

One of the comments was about reading any needed word documents in DT. My problem is that I haven’t been able to figure out how to do this.

I am pretty new to DT and maybe I am missing something. Anyone out there know how to do this?

Thanks,
geoff

Geoff,

just install AntiWordService, log out and in again afterwards and you’re able to import the pure text of Word documents into DT.

Geoff,
a further tip (once you have have installed AntiWordService) that I have found useful is to create a folder on your desktop, or elsewhere, to which you apply the ”save in Devonthink”-script. That will make you able to save Word documents you have written or get attached to incoming mail with one click. You’ll be able to classify, search and read them in DT as well as launch the original Word file whenever you need it. The same goes for PDF:s (preferences set to “Images&PDF/Copy files/Don’t copy” ”/Use pdftotext” and ”/Convert to Plain Text”).

In DT 1.6 these files, although converted to plain text files, were represented by Word and RTF icons the DT browser. Not so in 1.7. I’m told that this was a bug in 1.6. If so, it was a very useful bug.

I keep going to the Images & PDF section of the preferences and changing them? I know this has been covered before but I’ve got a bit confused again. Why is it necessary to choose “Don’t copy” and “Convert to plain text”?

It’s not really necessary as it’s possible to convert PDF documents to plain/rich text afterwards using DT 1.7.x. In addition, some users prefer to copy images/PDF documents (e.g. this simplifies the synchronization of multiple computers) or to reference them (then it’s easier to modify/open them in the Finder).

I have been unable to reproduce what was suggested by Mats in this thread (Sept 7).  I have installed AntiWordService and am able to "print" to DT.  I have attached the Save in Devonthink script to a "Test folder" on my desktop.  Ok, now what?  If I move a Word file into the folder, I would have assumed that it would trigger the script and that the file would both be placed in the folder and saved to DT.  Nothing happens in DT, however.  So what I am doing wrong?

[From MATS]
Geoff,
a further tip (once you have have installed AntiWordService) that I have found useful is to create a folder on your desktop, or elsewhere, to which you apply the ”save in Devonthink”-script. That will make you able to save Word documents you have written or get attached to incoming mail with one click. You’ll be able to classify, search and read them in DT as well as launch the original Word file whenever you need it. The same goes for PDF:s (preferences set to “Images&PDF/Copy files/Don’t copy” ”/Use pdftotext” and ”/Convert to Plain Text”).

In DT 1.6 these files, although converted to plain text files, were represented by Word and RTF icons the DT browser. Not so in 1.7. I’m told that this was a bug in 1.6. If so, it was a very useful bug.

You need to attach the “Action Import” script to the folder - the “Save To DEVONthink” script has to be copied to the folder ~/Library/PDF Services. Afterwards the print panel of every application will provide a popup including this command (and therefore you’ll be able to “print” to DEVOnthink). But this script of course does not require the “Action Import” script.

Is there any key combination that can be used to automatically copy a document you have open to Devonthink?  I know some other applications like Stickybrain allow you to copy and automtically post to the program with a key combination.

For applications that support Services, check under the menubar Application:Services:DEVONthink. For many applications, you will find that Cmd-Shift-9 and Cmd-Shift-0 will allow you to copy selected text to your DT database as plain text or rich text respectively.

Joe

Is anyone successfully using system Keyboard Shortcuts to add shortcuts for Script Menu entries?  I’d like one for “Add page from Safari” but couldn’t get it to work, as described in this other post.