«Broken or not yet complete data structure..» error on new CloudKit sync

Hi,

Im getting loads of «.manifest missing» error messages on my ipad after a week or so transitioning from classic iCloud to CloudKit (following the official tutorial somewhere on this page/forum). And upon verifying the database on my mac, I get the error-message in the title. Everything synced properly the first time, but the error suddenly came up today.

Anyway, I know I need to set up the sync location again from scratch. But just want to know what the proper way to solve this in my context is, because my DT library is very large, and it takes a while to sync. So I just want to do it properly :slight_smile:

Thanks

These steps should be sufficient:

  1. Disable the sync location on all devices except one Mac
  2. On this Mac clean the sync store
  3. Upload your database(s) again and maybe verify the sync store afterwards (just to be sure that it’s fine)
  4. Once the upload is complete, enable the sync location again on the other devices

It worked to begin with, but now Im back to where I started with loads of manifest-errors on my iPad. Any ideas on how to troubleshoot this? I dont even know where to start.

A little history if its relevant. Dropbox sync did not work for me earlier (a year or so ago) and Devonthink support werent able to help me fix that. So I subscribed to iCloud because I was told it was better. Legacy worked very well until I found out it doubled the space on my hardrive (?). So transitioned to Cloudkit in hopes that it would work better. But seems that it does not agree with my library. My library is about 15gb.

In DEVONthink To Go’s Home Screen, tap ? > Help > Appendix > Utility URL Commands and execute SyncDebugLog. Then manually initiate some syncing.
Lastly, tap ? > Contact Us to start a support ticket.

And do you need to carry 15GB of data with you? Just something to consider.

Yes, I need most of my library on both my iPad and Macbook. I executed SyncDebugLog and opened a support ticket. Thanks.