Bug in 2.1.7 - Sorting based on changed timestamp

Hi all,

I’ve maybe found a bug in the sorting of the elements.
Sorting based on changed (timestamp) is not possible - it will be sorted based on item type.

Please check - it worked in the past,

Thanks in avance,
Kind regards,

It happens in the IPAD Version

I just checked this, and sorting does work for me as expected on the iPhone. Confirmed that sorting on the iPad is broken as reported above.

Not seeing this here. Are you using the beta still or the public release? (They’re both available but you should be using the public release now.)
If it is sorting by Kind you would see the headers for each type, like Markdown / Plain Text / etc

On the iPad, you cannot make any selection other than Kind>Ascending. It’s like all the other buttons are disabled. Release version of DEVONthink 2.1.7, iOS 11 beta. Same configuration on an iPhone 6S and it works.

On the public release? I am not seeing that at all here.

See, on the public. I don’t know how to access the beta to be honest…

Public release of DEVONthink to Go 2.1.7, public release 3 of iOS 11, iPad Pro 10.5".

OK, so I went back and tried it again. I poked and I poked at the various button options and then finally the options started to work. It was just like it was a manual switch that was stuck, and after enough pokes it freed up. Weird. The OP might want to try this also and see if it helps.

I tried it again, every option - but as said, sorting based on changed timestamp does not on the iPad

This only happens in the German localization and will be fixed in 2.1.8.

Thank you