Bug with smart rules / Disappearing smart rules after fresh installation

Again: What kind of account is the new account?

Welcome @anubis

What kind of account is the new account?

New user account, no previous DT installation. Fresh DT3beta 1 installation.

All smart rules were showing directly after installation of DT3beta1. I just closed the app and started it again (without opening any database etc). At second start of DT3beta1 all smartrules had disappeared.

If this is a bug, please fix it with beta2. @cgrunenberg

Is there any way to manually re-import the standard smart rules of DT3beta1 (can you upload the according file here and let me know where to place it in the finder to get the standard DT3beta1 smart rules back?)

Existing DT pro 2 paid user.
Just downloaded DT3 and juggling with it since half a day with my DT2 bases.
Not paid DT3 upgrade yet but will (love it: general inbox + UI + inspector).

Again: What kind of account is the new account?

new account is not an account type.
It has to be specified as Administrator, Standard, Managed with Parental Controls, or Sharing Only.

  1. I completely uninstalled DT2 and DT3beta1 from my computer / old account according to this:
    To remove (uninstall) DEVONthink Pro Office completely from your Mac, trash the following files and folders (~ stands for your Home folder):
    :black_small_square: DEVONthink Pro Office
    :black_small_square: ~/Library/Application Support/DEVONthink Pro 2
    :black_small_square: ~/Library/Mail/Bundles/DEVONthink.mailbundle
    :black_small_square: ~/Library/Preferences/com.devon-technologies.thinkpro.*
    :black_small_square: All DEVONthink Pro Office-specific scripts in ~/Library/Scripts/
    :black_small_square: All DEVONthink Pro Office-specific workflows in ~/Library/Workflows/
    :black_small_square: All DEVONthink Pro Office-specific scripts in ~/Library/PDF Services/
    :black_small_square: Dashboard widgets
    :black_small_square: Bookmarklets from your web browser
    :black_small_square: The reference to the global inbox folder in your Finder’s sidebar
    :black_small_square: Keychain entries containing “devoncloudy”

If for some reason you need to fully uninstall DEVONthink from your Mac, trash the following files and folders (~ stands for your account’s home folder):

  • DEVONthink
  • ~/Library/Application Support/DEVONthink 3
  • ~/Library/Application Scripts/com.devon-technologies.think3
  • ~/Library/Preferences/com.devon-technologies.think3.*
  • All DEVONthink-specific scripts in ~/Library/Scripts
  • All DEVONthink-specific workflows in ~/Library/Workflows/
  • All DEVONthink-specific scripts in ~/Library/PDF Services/
  • Uninstall the DEVONthink browser extension, following the uninstallation process for the particular browser.
  • Bookmarklets from your web browser
  • The reference to the global inbox folder in your Finder’s sidebar
  • Keychain entries containing devoncloudy in the name
  • ~/Library/Mail/Bundles/DEVONthink.mailbundle
  1. I created a new ADMINISTRATOR ACCOUNT

  2. I installed DT3beta1

  3. I provided full disk access to DT3beta1

  4. I started DT3beta1 --> all smart rules were shown

  5. I closed DT3beta1 (without doing anything else before, I did not open any previous database etc)

  6. I started DT3beta1 --> no smart rules were shown

–> Why were the smart rules deleted after second start? If this is a bug, do not hesitate to ask me for further information if needed.

–> Is there any manual way to re-import them?

–> If yes, could you please upload the according file here: **
!!! German (!!!) version of standard DT3beta1 Pro smart rules !!!
** and let me know, where I should save it in the finder (I assume library > application support > devonthink3 folder)?

Strange. I can’t reproduce this issue and it’s unclear where the issue lies.

Check in ~/Application Support/DEVONthink 3 for a SmartRules.plist.

there is a smartgroups.plist but NO smartrules.plist

if you can not reproduce the issue, it will be difficult to solve this potential bug?
is there at least a possibility to help me to provide me the German (!) version of the smartrules.plist file of DT3beta1 Pro? So I could copy it to the appropriate application support folder?

Criss will have to weigh in on this, but it’s certainly an unusual bug since the file itself is missing. That makes little technical sense, just on the face of it.

Try unzipping this and putting it in the ~/Library/Application Support/DEVONthink 3 directory. The relaunch, quit, and relaunch DEVONthink 3.

SmartRules.plist.zip (1.1 KB)

Is this the English version of the smart rules? could you please upload also the German version, just for better consistency?

Did you load the ones I uploaded?

no, as I see that the strings in the source code of the smartrules.plist is in English, I would kindly ask you to upload the German version of it, in order to allow better consistency in my DT3beta1 installation, which is in German. Or should I change the string names in the plist code before copying it to the application support folder?

If what you are asking for is osx user preferences I am using an administrator account.

Thank you this has worked for me and so far this does not disappear again.

You have to delete both the SmartRules.plist file in application support and reset the preferences. Beta 2 will fix the bug (and deleting the file will be sufficient to get the defaults again too).

how to reset the preferences?

Quit DEVONthink 3. Then enter…

defaults delete com.devon-technologies.think3

…in the Terminal.

1 Like

WOW, after doing this and restarting DT3beta1 the smartrules re-appeared (but not the smartrules.plist in application-support / devonthink3).

After closing DT3 and re-starting it, the smartrules again have disappeared.

Strange… really strange…

Just customize them (e.g. add or rename a rule), this will create the file.

Indeed, this was the solution.

  1. reset the preferences
  2. adding an own smart rule (before closing DT3) --> the plist file is created
  3. closing DT3
  4. starting DT3 --> the standard smart rules are there…

THANKS so much for this workaround… This solved the issue. I hope my bug report helped you to fix it for beta2