Bug with smart rules / Disappearing smart rules after fresh installation

there is a smartgroups.plist but NO smartrules.plist

if you can not reproduce the issue, it will be difficult to solve this potential bug?
is there at least a possibility to help me to provide me the German (!) version of the smartrules.plist file of DT3beta1 Pro? So I could copy it to the appropriate application support folder?

Criss will have to weigh in on this, but it’s certainly an unusual bug since the file itself is missing. That makes little technical sense, just on the face of it.

Try unzipping this and putting it in the ~/Library/Application Support/DEVONthink 3 directory. The relaunch, quit, and relaunch DEVONthink 3.

SmartRules.plist.zip (1.1 KB)

Is this the English version of the smart rules? could you please upload also the German version, just for better consistency?

Did you load the ones I uploaded?

no, as I see that the strings in the source code of the smartrules.plist is in English, I would kindly ask you to upload the German version of it, in order to allow better consistency in my DT3beta1 installation, which is in German. Or should I change the string names in the plist code before copying it to the application support folder?

If what you are asking for is osx user preferences I am using an administrator account.

Thank you this has worked for me and so far this does not disappear again.

You have to delete both the SmartRules.plist file in application support and reset the preferences. Beta 2 will fix the bug (and deleting the file will be sufficient to get the defaults again too).

how to reset the preferences?

Quit DEVONthink 3. Then enter…

defaults delete com.devon-technologies.think3

…in the Terminal.

1 Like

WOW, after doing this and restarting DT3beta1 the smartrules re-appeared (but not the smartrules.plist in application-support / devonthink3).

After closing DT3 and re-starting it, the smartrules again have disappeared.

Strange… really strange…

Just customize them (e.g. add or rename a rule), this will create the file.

Indeed, this was the solution.

  1. reset the preferences
  2. adding an own smart rule (before closing DT3) --> the plist file is created
  3. closing DT3
  4. starting DT3 --> the standard smart rules are there…

THANKS so much for this workaround… This solved the issue. I hope my bug report helped you to fix it for beta2

@BLUEFROG what I did not understand from the documentation (maybe due to my bad English), do the smart rules run always in the background and directly apply to any (new) file in the database? Or do they only apply when I click on them? Is there an explanation of the standard / sample smart rules in the documentation? Or then in the manual? I would like to better understand the smart rules (and I have read the documentation chapter about smart rules, but there are some open questions about the samples that you have included)

This depends on the smart rule, see popup menu right after “Folgende Aktionen durchführen:”.

Smart rules are covered in the Help, in the Automation chapter. Also, events and actions are listed in the Appendix.

Smart rules trigger per the specified event trigger. They don’t trigger by merely selecting the smart rule in the Navigate sidebar.

They can be applied to chosen items via the Apply Rule command. Again, this applies to selected items.
You can also drop items on a smart rule to perform the actions on them.

They can also be run via the Perform Rules found in the Tools menu. This runs the rule as it’s specified. This is a powerful option and you should be sure before running it. If you are using broad criteria, like Kind is Any Document in all databases, it could lead to undesirable results.

I hope that helps.

1 Like

Thanks to both of you! Wonderful support! The best support ever! DT3 alone is great, but with @BLUEFROG and @cgrunenberg the experience is simply unbelievable!

You’re very welcome! :slight_smile:

This ~/Application Support/DEVONthink 3 doesn’t even exist. This path it only takes me to Uses>home.

You missed Library before applications :wink:

~/Library/Application Support/DEVONthink 3
Correct one.

Thanks. Worked for me.

Ugh… good catch. Corrected above

1 Like