Buggered up Change to CloudKit

Dear Forum,

I have only too late found the instructions to switiching sync methods and just went ahead and switched sync methods. Now, luckily all my files are still available on my main macbook pro (as I guess they should be). However, I cannot seem to be able to make DTTGo play nice. I only see file icons and options to download the file and then nothing happens. I even tried to sync both places through bonjour and then switch back but no joy. How do I go about fixing this, please?

thanks for taking the time, stay safe,


Which version of DEVONthink To Go do you use and which sync locations do DEVONthink and DEVONthink To Go use currently? Is File > Verify & Repair Database… on the Mac successful?

Hi there, that was quick…

I am using the latest versions of both, DTTG and DTPO. Verify and repair did nothing to help sync. It says databases are ok. I ran a trial and added a file and rearranged some folders and nothing happenend on the DTTG end. (even after manually syncing on the mac…although I wonder a successful sync was not reported, but that is not always the case, right?)
Edit: after a wee while the changes were synced and the newly added file is actually available in DTTG. However, older files are not and behave as described: privew icon with download option and nothing happening.

I then used a not so important database to rebuild as a trial and that crashed DTPO.

any pointers?

DEVONthink Pro Office 2.x or actually DEVONthink 3.x? Anyway, please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com - thanks!

Will do. I use DTPO 3

but report has been sent. thanks.

Thank you for the logs! The bug report didn’t include any crash logs, did DEVONthink really crash or just freeze? DEVONthink isn’t responsive while rebuilding a database.

1 Like

mhhh. then it must have frozen. systems monitor flagged it as non-responsive and I still let it run for about 60min with the mac almost melting. it was rendered utterly useless in it’s enterity so I then forcequit DTPO. (in hinsight a mistake then, maybe.) But how long should it take to rebuild a database? any more insight as to why the the snyc isn’t working as expected? would I assume it to be correct that from the logs my databases seem to be in order? (apart from about 1700 orphaned files that appeared out of nowhere after I restarted DTPO after the “crash”/unresponsiveness?)

if so, do I need to clean / wipe / incinerate the old legacy iCloud sync stores?

This depends basically on the size of the database and the speed of the computer. Seconds, minutes or even hours are possible.

Unfortunately not. I would suggest to open a support ticket.

little update:

opened a support ticket.

what I did in the meantime is tick both sync stores as active in DTPO (legacy and cloudkit) and then went back to DTTG and deinstalled it and installed a new version and checked icloud legacy sync and “download all”. now things seem to work for me again. so, what now?

  1. can I uncheck “cloudkit” in DTPO?
  2. while the performance of cloudkit is supposed to be much better than legacy I am not convinced. How should I go about trying it again? or can I leave it as is?

thanks for taking the time.

  1. Don’t have Legacy and CloudKit syncing the same databases.
  2. You can uncheck CloudKit if you’re not using it.
  3. Convinced in what way?
1 Like

Ok. Will untick the cloudkit box then. However, I thought cloudkwit was supposed to win with regards to performance and other under the hood things. Any chance to make it work or any pointers on how to start another run at it?

You should sync one database at a time for the initial sync.
After that our experience and reports have been CloudKit being more reliable and faster.