Bugs. Not sure where they go!

  • Produced a bunch of documents that were in the global in box.
  • Tagged them.
  • Selected them by selecting the a tag they all had in common.
  • Selected MoveTo from the pop-up menu.
  • Moved them to a folder in a different database.
  • They show up in the database I moved them to.
  • The item header remains in the global inbox.
  • When I select one of the items in the global inbox, coverflow shows a message saying the document could not be fund.

DevonThink Pro Office 2.01.

I’m also not sure where to submit bugs…

DT 2.0
Select say an image in the database and bring up the Info window. Now select the title and cut it. Type in a new title and press enter, tab, return, whatever. Note that the title on the item in the database doesn’t change but the new title remains in the Info pane. Now select another item in the database. The previous item still displays it’s original name. Now select the original item again and the original title is back in the title field. Ooopsie!

DT 2.0
Another issue is the following. If I have the Info window open and I’ve been say, typing in it, and I click on a another item in the database I have to click twice to get the item selected. The first click makes the database window the active one. This means two clicks every time I want to select a new item in the database and as I’m using the Info window a lot for entering comments this is really slowing me down. I know original Apple UI worked this way but nowadays applications normally use Keep clicks or whatever it’s called so that clicking on an item in a window not only activates the window but the click also activates the item clicked on.

Is there any possibility of displaying the Info window as a panel at the bottom of the database window rather than a separate free-floating window. This would really make life easier for me…

One can always submit bugs by following the ‘Support’ link in DT’s Help menu.

As to the issue reported, I don’t see this myself. If I change a document’s name in the Info pane from the Three Pane view, the change is reflected immediately in the database view. In what view setting are you seeing this?

If this helps at all, command-click will select a new document from the list without the need to click twice.

I’m working in Icons view. Did you select and cut the entire title before entering the new title?

This won’t work as it multiple selects the items. In any case I maintain that it should not be necessary to use a modified click to do this. A single standard click should select the element clicked on especially when the front window is a floating panel like the Info window. This is standard practice in most other applications I use.

I just tried it in icon view:

  1. Select a document’s icon
  2. Bring up the Info pane with Cmd-Shift-I
  3. Cut the document’s title with Cmd-X
  4. Type a new name
  5. Hit tab, and the new name is reflected in the icon view.

I just tried it in icon view and it does select multiple items. In the three pane view, it does not. Regardless of one’s preference for how a click should behave, at a minimum I would expect that it should function consistently across the various views.

I’ve done some more testing and the problem occurs if you

  1. Cut the name
  2. Paste into the comments field
  3. Click on the name field again
  4. Type in the new name
  5. Tab, return etc. Note that name doesn’t change
  6. Select a different file
  7. Reselect the original - note that the original name is back

Standard UI behaviour in OS X is that Cmd-Click is for discontiguous multiple selection so technically it is working correctly in Icons View.

I just ran into another issue…

I have DT set to open nothing on launch. I then go to File>Open Recent and select the file I want to use. The progress bar for ‘Initialising & verifying’ the database appears but the window for the database does not open. I have to choose the database a second time from the Open Recent menu! Even if I already have another database open when I choose a database from the Open Recent menu the window doesn’t open until I choose it a second time. Note that double-clicking on the database in the Recent Databases section of the sidebar doesn’t seem to suffer from this problem.

Actually Show Details in Icons view would work for me except that I can only edit the name. I’d need to be able to edit the comments as well as tag the items.