Can add tags, but not delete (Leap + DTPro)

I recently purchased Leap to manage tags in an effort to begin organizing my documents more effectively. I went through and started tagging some images in Leap and then in DTPro indexed the folder that contains the images. All the tags appeared and were appropriately attached to their respective images.

Then, I went and added a new tag “Testing” to a new image to see what would happen when I remove a tag. Upon going back into DTPro it immediately recognized that a file had changed and incorporated the new tag. I then went back into Leap and deleted the tag and, unfortunately, the tag remains attached to the image in DTPro. It neither automatically identifies the changed file nor identifies the change when forced to via “Update indexed items”. Just to make sure Leap was reporting the tags correctly I checked in the Finder and, sure enough, the tag was stripped from the file.

Has anybody encountered DTPro failing to recognize changes in OpenMeta tags?

I am seeing some inconsistency in Leap’s Tagging. I just downloaded it onto a new Mavericks machine and noticed it applied kMDItemOMUserTags sporadically, instead of just _kMDItemUserTags (“Mavericks Tags”). The OMTags weren’t deleted when I deleted the Tags in Leap, so they didn’t disappear in DTPO.

Again, this has been inconsistent (which makes it harder to troubleshoot).

I just tried your method, korm - step by step. New image, fresh launch of Leap and DTPO on 10.9.2. All worked fine until step 6. No, deletion in DTPO. Checked the xattr and sure enough, Leap had applied kMDItemOMUserTags that aren’t deleted when deleting the Tag in Leap.

Yeah, this is an Ironic Software issue. With a virgin file, it is writing kMDItemOMUserTags (OpenMeta) to the file, along with _kMDItemUserTags (Mavericks tags). It appears DT is picking up the OMTags as primary if present.

Subsequent changes in Leap are written to the Mavericks tags (? another issue!) but they are not changed or displayed in DT since it’s displaying the OMTags. Unfortunately, the OMTags are not deleted when deleting the Tags in Leap (though they are removed from the Maricks Tags). Again, this has no effect in DT since OMTags are still present in the file metadata.

@korm: Even if I manually remove the Tags, I haven’t seen step 6 yet. Odd.

I don’t recall this situation, but that doesn’t mean I haven’t encountered something similar before and have just forgotten it.

I’ve not seen anything like this recently, perhaps because I gave up on normal groups included for tagging a long time ago. I found that assigning regular tag(s) to groups, even if the group name and a tag name were the same, to be far more reliable. The only advantage that I saw to having tagging enabled for groups is that it can be a classification shortcut in a new and/or small database where the AI doesn’t work as well.

I’m having trouble following the line of thought here - either that or we’re talking about separate problems.

My problem is:

  1. Index a folder of files in DTPro

  2. Go and tag a file in that folder with Leap

  3. Go back to DTPro and the new tag automatically appears

  4. Now go back to Leap and delete the tag

  5. Tag is deleted in Finder, but stays in DTPro

No, you are following correctly.

What’s happening is this (ignoring the fact that the files are indexed, as it doesn’t affect the problem)…

  1. You Tag a file in Leap. This is added as an OpenMeta Tag and a Mavericks Tag.
  2. DEVONthink updates the index and adds the OpenMeta Tag, not the Mavericks Tag.
  3. In Leap, you delete the Tag but only the Mavericks Tag is deleted, not the OpenMeta Tag.
  4. DEVONthink, seeing the OpenMeta Tag continues to display that Tag. Since Leap didn’t change it, no change happens in DEVONthink.
  5. In Leap, you can add 100 more Tags, and they will be added to the Mavericks tags, and never appear in DEVONthink due to the presence of the OpenMeta Tag(s) that are present.

PS: Deleting the Tag in the Finder has no effect on this, again, because the OMTag is present (and the Finder isn’t displaying those).

Make sense?

Yes, that makes sense. I’ve been conversing with Tom Anderson at Ironic via e-mail and he is telling me:

What you describe makes sense, but I’m having trouble reconciling it with what he is saying, since I had no OpenMeta tags to begin with and have only been tagging with the latest version of Leap on Mavericks.

The next release of DEVONthink will prefer Mavericks tags on Mac OS X 10.9.x and use OpenMeta tags only if there are no Mavericks tags. This should work around the inconsistent tagging by Leap.

That’s actually correct. But it should be added to the root group in that case (so that it’s not only located inside the Tags group), the next release will fix this too.

So how will this fix affect documents that are not indexed, when a tag is deleted? Currently those documents are also moved to the root group.

I’m having a challenge understanding how it will be possible for documents to have their group tag (or regular tag for those users who prefer to keep documents only in tags) removed and not then be moved to the root group? Will the documents remain in the tag group, and still lose the tag?

It’s not limited to indexed items.

The tag will be removed (no matter whether it’s an ordinary tag or a group tag). If there are no more replicants outside the Tags group anymore, then it will be added to the root group.

If you are using Group Tags, and have a file in a Group, it will have a Tag for the Group. If you remove the Tag, then it seems the obvious reaction would be to move the file out of that Group.

I agree, which is how it works now. From what has been described, I still don’t see how the behavior will change in the next release.