“Can’t create database folder, path exists already”

I’m migrating my half-dozen or so databases from WebDAV to iCloud sync. For my largest, just over 1 GB, I’m consistently receiving this error message when I try to upload the database to the new cloud store:

I’ve cleaned the cloud store, rebuilt the DB in DTPO on the Mac, renamed the database, to no avail.

Suggestions appreciated! And thanks for giving us iCloud sync. I think it will be good once I get past these small hurdles.

Go into System Preferences > iCloud > Manage. Select DEVONthink To Go and press the Delete Documents and Data button. Then try to set up the sync location again.

Thanks, Jim; that seems to have done the trick.

Is there any database size you guys have found, above which there are problems with iCloud sync?

In other realms/apps, iCloud sync seems to work accurately but slowly, on its own schedule, and it’s not very transparent.

No specific size, other than exceeding your storage capacity.

It looks like iCloud’s internal machinations are the rate-limiting step in database sync, correct?

Once I have set up iCloud sync on MacOS and initially uploaded that data to iCloud, those databases become available on iOS devices, and sync begins. But the actual content of those databases seems to take a long time to populate. I presume this is a quirk of iCloud sync, because it was much faster to sync with WebDAV (thought I had other issues with that method).

We can’t account for or control iCloud’s performance, so YMMV (as it does with ANY remote sync location). And yes, iCloud initially provides a placeholder, then content when it syncs.

However, this is generally only appreciable on the initial push and import. Obviously, large amounts of data take more time to sync. Subsequent syncs are generally faster due to less data being transmitted.

Thanks for the explanation, Jim. iCloud sync will be a game-changer for me (and I’m sure for others) once I get everything set up and running.

No problem. We have generally found it to be a good solution for personal syncing, when a remote sync location is desired. Not saying it’s “better” than another option, but it’s even easier to set up and is available on all Apple devices. Cheers!

When I try to “Delete Documents and Data button” iI get the message “Documents & Data for “Devonthink To Go” couldn’t be deleted.”

At this stage there is 13.4Gb (1.5Tb available free) of data there. I have tried from the iPad but that doesn’t work either. Tried turning OFF the iPad, rebooting the MAC and not having Devonthink running. Have left things for an hour for iCloud to settle down but error msg is still the same.

There are three databases one is 32Gb on the MAC and the others are about 6Gb each.

Any suggestions please ?

You said there is 13GB in the iCloud report, and here you’ve said you have at least 50+ (assuming “the others” is two, but likely there are more). iCloud is most likely still pushing data to their servers, and that amount of data will not be done in “an hour”. I’d say you’re just going to have to wait this out until it’s finished uploading all the data before you can delete it.

Thanks yes I think you’re correct, it’s now showing up as 20Gb of Devonthink Data in iCloud, so will leave it for a day and see where we get to.
Thanks for your rapid response.

No problem. Cheers!

It took a couple of days for iCloud to finish its uploading and organization. Now that it’s finished, subsequent syncs of incremental changes have been rapid and smooth.

iCloud sync has helped me get around a major issue with WebDAV sync, likely having to do with my faulty network-management skills. I had my WebDAV store on a Synology drive running on my LAN, with DynDNS providing a domain name for WAN access to my LAN. I could either set up sync-store access with a 192.168 prefixed private IP address, usable only when on my LAN; or with a public DynDNS-provided IP address, usable only from outside my LAN.

I’m sure there’s a way to fix this but I’m not a network engineer, so……

That’s our general experience as well.

And yes, running your own WebDAV server can be beyond the skills of a layperson, especially when you’re trying to set up accesss from outside your network. (PS: I am not a network admin either, and I don’t try and access my WebDAV server from the outside. I like my data in my hands and not out in the open, just like I don’t walk around flashing the contents of my wallet! :mrgreen: )

Would like to chime in…

I got the aforementioned error on DTTG as well: path already exists. However, the whole process seemed so unclear that I switched back to Dropbox and wanted to ask here first…

I tried this:

  • Uncheck Dropbox sync on Mac.
  • Uncheck Dropbox sync on iPad and iPhone.
  • Then restart DTPO on Mac and check iCloud sync.
  • Check iCloud sync on iOS devices as well. Error occurred.

Weird thing was that on Mac, the “wheels” for my syncing databases only turned for a few minutes on iCloud although my sync store on Dropbox is 1 GB in size. Wouldn’t that take ages to upload on iCloud? I would like to make sure, that everything is up there before I turn on iCloud sync on iPad. Is there a wa to tell when DTPO is really finished uploading? Will patience prevent the error message? :wink:

Thanks and best regards,



As noted above: Go into System Preferences > iCloud > Manage. Select DEVONthink To Go and press the Delete Documents and Data button. Then try to set up the sync location again.

Maybe not ages, but likely won’t be done in a few minutes. That’s iCloud’s job, not our sync’s.

That’s not really possible, other than checking the System Preference above periodically to see the size change.

Yes. When DEVONthink’s spinner and Window > Activity stop, it’s done syncing… but that has nothing to do with what iCloud does. Sync is done locally, then iCloud uploads to Apple’s servers, then to devices using your Apple ID. This means databases may not be immediately available to sync on the other devices. The initial sync requires patience, as we have no control over the speed and reliability of iCloud’s process

I am receiving this error message when trying to set up sync with iCloud. I have deleted the DTTG docs and data, but the error message is persistent. I have less than 5GB of databases and 184GB of available iCloud storage. I have restarted DTPO and my computer (Mac Pro OS Sierra 10.12.6). Any suggestions, please?

@krysteau: In DEVONthink To Go, select Help > Contact Us to start a Support Ticket.

Help please. I’m getting this “Can’t create database folder,…” alert on both my new 11 inch iPad Pro and on my iPhone XS Max. I can’t even find DEVONthink To Go in my list under iCloud -> Manage on either device. I thought my Mac was syncing OK (it’s only a few weeks old also, everything is new), but it is giving the same error.

Thanks in advance for any help.


@ChemBob: Start a support ticket by holding the Option key and choosing Help > Report Bug in DEVONthink.