Can’t find databases after crash

Not really, I inspected it and everything is there on my hard drive. Additionally, almost all of my files are stored in Devonthink, everything has been migrated. This is the reason I am so unhappy with the service offered now…really…

1 Like

Restore your DEVONthink database(s), then.

Milos, your screenshot does not show that the data is gone. Lets start by going to the Finder location where your databases are usually stored (by default that will be yourusername/Databases). Can you see the databases here? What are the file endings of those databases?

There is no such thing. Quite apart from the fact that we haven’t even established that DEVONthink has caused any trouble at this point. However, task in hand: let’s get you back up and working.


According to the screenshot the databases were not yet opened (and that’s actually an intended step after the crash to avoid that a damaged database could cause endless crash cycles).

1 Like

I’m currently assuming it will be possible to open the databases from Finder; possibly after “resetting” the file extension (if the OP is using encrypted databases). I’ve never seen anybody here report the whole database lost following a DT crash, so it seems unlikely here, too. In fact, I can’t even come up with a mechanism likely to cause a total loss on crashing, although that could be technical ignorance on my side. Let’s wait for Milos to come back and report what’s in Finder and hope for the best :slight_smile:

@Milos_1989 you just have to open the databases. Double click them in Finder or use Script: Open or close databases.

1 Like

That’s assuming they are not encrypted, in which case the automatic change to the file extension on opening will not have been reversed (so the file extension will currently be sparseimgae rather than dtsparse, and will need reverting).

Here is the screenshot from my iPhone. Here you can see that my databases went lost.

Again: no, that screenshot does not show that databases have been lost. Again, I suggest you go to the Finder location where your databases are stored on your Mac and report back what you see there.

1 Like

Note: This post is offtopic

I read something about that … Does this mean the way the linked „Open or close databases“ script tries to open sparseimgae won’t work? I didn’t test it as I never use encrypted databases.

I receive following mistake when I try to do that: ,Die Datenbank, die Sie versuchen zu öffnen, scheint entweder von einer anderen Kopie von DEVONthink 3 verwendet zu werden oder sie wurde nicht ordnungsgemäß geschlossen. Wählen Sie ‘Fortfahren’ um die Datenbank dennoch zu öffnen, wenn Sie sich sicher sind, dass sie nicht von einer anderen Kopie von DEVONthink 3 verwendet wird.´´

It says that the database I am trying to open is being already used or that it wasn´t properly closed. I can choose if I want to continue with it or not.

Now I am confused. Which copy could be used since there are no databases in my Devonthink 3?

That’s fine - select “Fortfahren”; the database was not closed properly when DT crashed, and is marked internally as open. When you select to continue, DT will perform a validation of the database.

Aufgrund des Absturzes ist das der Fall, Fortfahren sollte genügen.

How can i proove to you that my databases have been lost? I think you can trust me on that, since I know what I have on my Macboo and since I have synchronized all of them using iCloud Kit synchronizing process. Of course that I can´t provide you with any evidence before/ after since the databases went lost :slight_smile: I mean, I know that you are defending the app and it is fine for me, but sometimes you need to hear to users opinion…

Ok, perfekt. Danke dir. Die sind jetzt wieder aufgetaucht.

You may have read about it here a while back.

DEVONtech seem to have built in some magic since the days; I just force quit DT with an encrypted test database open, and it was automatically renamed .dtsparse when I next opened DT. A such, I cannot simulate a situation in which the database is left open and still uses the file extension sparseimage next time the script is run.

1 Like

Thank you :slight_smile:

1 Like

This is likely to make proving to me that your databases are lost rather difficult - well, for any typical definition of the term in relation to data, that is.

1 Like

Thank you for your advice. They are now there.

Sorry for overreacting but this was first time experiencing something like this. It is really unconfortable to be confronted with something like this knowing that I am not a super user but only a regular one, not having one milion of databases and scripts being used…

Can you assume what caused this behaviour from Devonthink3? I want to prevent it and I really want to assure that the product is 100% correct and ,clear´´.

1 Like

That’s alright :slight_smile: Milos, do you have a comprehensive backup strategy? If not, please take this shock as a trigger to make sure your data is backed up (remembering that sync is not backup). The more valuable it is, the better your backup strategy should be.

I can’t guess what caused the crash for you today; what is apparent is that actually everything then worked as it should - DT still worked, it protected itself by not automatically reopening the databases, it recognised that the databases were not properly closed, and it will have verified them when you selected “Fortfahren”. You said that you had opened a support ticket - if the logs were attached, then DEVONtech may look into any cause of the crash. Certainly if this experience repeats itself, you should assume DT may be responsible and report using Help > Report Bug (press the Option key to see that menu entry).

Reports of crashes are really pretty rare here in the forum; I trust DT with both my personal and professional digital life. I would not do so if I were worried about the quality of the product.