Cannot edit markdowns directly in DevonThink

I just noticed that I can no longer edit markdowns. I looked in the settings of DevonThink and there I set documents for editing. Unfortunately no success. Do you know this problem?

What versions of DT and macOS are you using? If, for some reason, you can’t see the edit screen for a markdown document have you tried the control + CMD + X shortcut?

Otherwise, what exactly do you mean when you say “can no longer edit”? Do you mean the record appears to be locked or do you mean you cannot get to the edit screen?


When I use the ShortCut, it looks like you can edit the Markdown file but once you can’t write anything. That was definitely different once. I usually use Typora to write markdowns. In DevonThink I only make notes from time to time. My DevonThink version is 3.8 My Mac version is 11.6.1

You are misunderstanding based on your use of Typora. DEVONthink doesn’t edit in the rendered preview. You edit the source.

Choose View > Document Display > Side-by-Side and you’ll see both the source and rendered view. This can be set as a preference in Preferences > Files > Markdown > Markdown Display.


In the document viewer I have also set the view side-by-side as well and I am not trying to edit the rendered document. My intention is to edit the raw form so that it shows me in DevonThink or Typora. When I start typing the Mac hint tones also sound as if something is locked or not allowed.

Check in list view to ensure the file is not locked. (Control + CMD + K toggles the lock.)


Nothing is locked

If I have written something before in Typora, I see this also in DevonThink in rendered form. But I don’t see a single letter in raw format.

Does it make any difference if you give the DT record a .md extension?


have added an extension to the dataset. Unfortunately, I do not see the extension. It is not displayed. But no other extension is displayed either. No .rtf - no .txt

DT > Preferences > General > Appearance Tab and check Show filename extensions - although it sounds as though merely seeing the extension may not make any difference.

Edit: What happens if you create a new markdown document in DT? Can you edit and preview that?


I also can’t edit any new - in DT - created Markdown files.

Sorry to ask a silly question (I’m not being rude!) but you are typing in the edit window rather than the preview window aren’t you?


All good. No - really not. Look…

My final idea, before summoning the Real Experts ™ for help, is to try restarting DT. If that doesn’t resolve the problem I’m afraid I have no more ideas: sorry!


I have restarted DT several times and unfortunately nothing has helped. I am totally at a loss… but thank you very much for taking care of this and trying to help me. Thanks a lot

Not at all: so sorry not to be of more help.

Let me summon @BLUEFROG - with apologies to him for not being able to get further with this.


Oh, all right. Thank you for bringing in another colleague. I would have written the whole thing in an e-mail otherwise. But it’s a lot easier that way. Thank you

I’m a mere user. @BLUEFROG is the real thing: he actually knows what he’s doing! :grinning:


1 Like

Maybe he will become aware of this. I hope