Cannot get DT and DTTG to sync!

This has worked in the past and I don’t know what has changed. In DT I have the iCloud kit selected and the database shows up. Bonjour on the computer is not connected.

In DTTG I have the location as iCloud kit and the database I am concerned with is turned on. On the iPad it says Bonjour is turned on; I don’t know where the port or password came from.

It appears to be syncing but does not. There are about 257 items on the computer that do not appear on the iPad. If I try to “sync database” from the computer, it does not appear to do anything and nothing appears in the Window->Log file. However, on the iPad when I go to the location-> database, it gives a current time that it has synced.

I’ve been worrying with this for longer than I care to admit. Does anyone have any suggestions??

Bonjour has nothing to do with CloudKit or any other sync method. They are all independent.
As has been discussed often, when you have a sync issue, the first things to check are:

  • What is reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, tap it. What is reported?

Also, why are you using a remote sync option, e.g., CloudKit?

Thank you for the response.

There is not any info in the Window > Log. None.

The little cloud on the iPad is the sync icon? There is no triangle on it.

What else could I use other than CloudKit? I don’t really care what method I use, I just want it to sync. I’ve not done this for awhile and the settings I had used to work.

As soon as I posted that, I looked at the iPad again. There was a triangle next to the sync icon. It says “Couldn’t publish Bonjour. NSNetServicesErrorDomain -72000.”

Now it’s saying “Last synchronized with: iCloud (CloudKit), today, 4:51PM.” But there are still those 257 items that are on the computer and have not synced.

There is still nothing in the Window > Log.

Unless a remote sync is needed, a local sync on your network is recommended.

There is a forum post on syncing: Sync Types Explained. This is a good place to start.
There is also one specifically about Bonjour: Bonjour Simplified

Sync is also covered in the Help for each application:

  • For DEVONthink, sync is covered in the Help > Documentation > In & Out > Sync, Preferences > Sync, and Troubleshooting > Sync Issues.
  • For DEVONthink To Go, sync is covered in the ? > Help > Sync section.

Manuals can be downloaded here: Manuals

OK. Let me ask you this. On my computer this db shows a total of All Images, 6; All PDF docs, 2083; Duplicates, 19. On the iPad the little “I” info shows Groups, 2; PDFs, 1848; Images, 5; and SmartGroups, 3.

On my iPad I just deleted the DTTG app and reinstalled it. I was able to sync BUT I have the same approx. 250+ discrepancy between the computer and the iPad. So it is syncing but I’m not getting everything synced over. Is there some setting that would keep certain documents from syncing while allowing others to sync?

And I’m still not seeing anything in the Window > Log that gives any info.

As you can tell, I don’t use DT a lot, so please forgive my ignorance.

So the iPad<>iCloud sync is working
How about the Mac<>iCloud sync; Does that show the current date?

These are smart group numbers. That is not the same thing as you’re reading in DEVONthink To Go. What does File > Database Properties show for the database in DEVONthink?

Screenshot 2024-06-10 at 6.14.01 PM
And this is what the iPad shows for the same db.

On DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket. Thanks!

Conventionally, only on the desktop DEVONthink is Bonjour turned “on” to accept incoming, and on DEVONthink ToGo (iOS device) keep Bonjour turned “off”. Only one device on a network can have Bonjour turned “on”.

Meantime, they’ll get you supported via the “ticket” you send it. Might be interesting if you report back here what the problem was and how you resolved it.

I have two iPads that I am trying to sync with my desktop (MBP).

I decided to use one iPad and experiment with it. I’m afraid I have taken a rather heavy-handed approach to this, but I was getting no where and didn’t feel I had a lot to lose. I totally deleted the app from my desktop and iPad.

I then reimported the database I was concerned with (I had exported it prior to deletion) on the desktop. I turned on iCloud. I then went to the iPad and made sure there was no data there. Turned on iCloud there. And everything synced just fine. So I thought I had the problem solved.

I went to my other iPad and did the same things. I’m sure this was not the most efficient way to get this done, but it seems to have worked.

I only have one question left. Before I started all this, I had several databases in DT. I have only put one back in. When I go to the DT icon in the dock and right-click on it, it still shows the databases that are no longer there. How could I eliminate these? There is what I see when I right-click. It’s only the last item that is actually still intact.

I appreciate all the suggestions. I’m sure someone with more knowledge of DT could have resolved this otherwise, but I’ve got it where I wanted it, so I’m happy.

Thanks again for all the input.

That is not DEVONthink’s doing. That is controlled by System Settings > Desktop & Dock > Recent documents, applications, and servers. Setting this to None, then quitting an relaunching DEVONthink clears this. But bear in mind this is global, so you also lose access to the File > Open Recent menu and the Recent Databases in the Navigate sidebar. You also lose this ability in other apps.