Cannot highlight certain pdf documents

I will check again in which cases this occurs. It is only in some cases!

@cgrunenberg I am having the same issue as well.

I am on OSX11.6 and used DevonThink 3.8.

This is not the first time that I am having this issue (not being able to highlights imported PDF).
I was searching the forum for a solution and found that thread.
I confirm that CONVERT > PDF (PAGINATED) solved the issue.

That’s a workaround and hope to see an update to solve that bug (don’t tell us it is not bug…).

Thank you!

1 Like

Welcome @mukei

It is a bug, just not a DEVONthink one. It’s an issue with Apple’s PDFKit framework, an issue they would have to fix. We are already employing workarounds for their bug but we can’t get around all of them.

@BLUEFROG thank you.
I went through other post after sending my message and understand better the situation.
Thank you for taking the time to reply.

I hope Apple provides a fix soon, but it seems to be an old bug they are not really urged to fix… :sob:

You’re very welcome and yes, we continue to hope Apple will fix these issues. Thanks for your patience and understanding.

Could you share more? Where can I find this preference?

I’ve run into these problems and have not been able to avoid them by using OCR to make a searchable PDF or converting to a paginated PDF. Thank you in advance!

See page 246 of the the user guide (also available through the in-app Help):

Note also the contents of the previous page of that guide which tell you how to access hidden preferences.



Thank you @Stephen_C! I should have made the user guide and in-app help my first stops when looking for more info :blush: It’s working great now!

Glad to have helped. The user handbook (also via in-app Help) is a wonderful resource and is assiduously updated for every release (both major and minor versions).



Is there a way to post here what should be put in the Terminal? I’m also having this problem but I’m not savvy enough to know the language to input and I can’t figure it out from the manual. Thanks!

best to start a new thread and be specific of the problem, what you see, what you tried, and what you expect. if a PDF perhaps give a url to where others can try or upload it.

1 Like

Did you even read the page in the documentation @Stephen_C quoted from? The procedure is explained verbatim there.

1 Like

@chrillek not only did I READ it, I TRIED it. But for those of us not super knowledgeable about working with terminal, it’s hard and I don’t even know what I’m doing wrong. Nevertheless, one of the previous comments worked (PDF Paginated) so I will do that for now and wait for the update.

1 Like

You don’t need to use Terminal for the majority of the hidden preferences.

See this blog post…

Thanks @BLUEFROG - the terminal command didn’t work but the link inside of the documentation did!

(too many of my pdfs were uneditable, now they aren’t)

Welcome @symptomatic

Glad the link helped.

(too many of my pdfs were uneditable, now they aren’t)

Do remember this sentence from the documentation: Note: This does not eliminate the potential for problems with certain PDFs.

I had a similar problem and can confirm that this worked, while hidden preferences did not. The document I’m looking at is a legal document, and I suspect it was locked by the sender in some fashion.

1 Like

OCR scanning again inside DT works. But the hidden property ‘ForceEditablePDFs’ can’t be found.

defaults read com.devon-technologies.think3 | grep -i ForceEditablePDFs

I’m running DT Pro 3.8.5

In Version 3.9, neither of the terminal way or the visual toggle way in the help document worked for me. I do hope DEVONthink team can fix the issue. This is the greatest barrier for me to transfer to DEVONthink as a daily PDF reader.

Is the problem unable to toggle the hidden preference, or “certain” PDFs not readable?

For the former, what happens when you try?

For the latter, are these PDFs readable in other apps, e.g. Preview or Adobe? Are you sure the PDFs are structured correctly?