Cannot open files


I am not 100% certain if it’s an issue with the DT3.0.1 version or Catalina’s newest beta, but the double clicking to open function has been problematic on my Mac. Even when I use right-click and open, it rarely works.

I’ve restarted DT and mac, but neither has worked.

Is there anyone else having the same problem?

Welcome @owlinprime

Have you enabled Preferences > General > Double-click opens documents externally?

PS: Unless you are explicitly beta testing and reporting, you should not run a beta operating system on a device you need operating as expected.

Hi Bluefrog,

Yes, it’s enabled. I am fully aware of the risks and potential bugs that may come up in beta testing and it’s not an issue that really bugs me now (I can always show file in folder and then open it from there), but thought you might want to know about this.


What kind of documents did you try to open?

Mostly pdfs and occasionally pages and md docs. I haven’t really figured out why some can be opened at certain times but not other times. It seems so random.

Could you please send ~/Library/Application Support/DEVONthink 3/Console.log to cgrunenberg - at - Thanks.

Done. Thanks!

Thank you for the log! Are all these items indexed and located in iCloud Drive? And are they actually downloaded before trying to open them? According to the logs iCloud Drive seems to cause huge delays.

Interesting point. Yes they have been downloaded.

Also I just tried to open files (docx and pdfs) in local databases folders that are definitely not cloud stored, but they are still not opening.

What’s the path of these files (see Info inspector)?

For instance, /Users/xxxx/Databases/1 - xxxx.dtBase2/Files.noindex/docx/b/filename.docx

Which version of Catalina do you actually use? So far we couldn’t reproduce this and haven’t received similar reports, therefore if it’s a beta, then this might be the cause.

10.15.1 Beta (19B68f).

I guess I will wait and see if the problem solves itself then. Thanks!