Can't change Plain Text Font

I’m experiencing a bug in DTPro 2.6 where the plain text color preferences are not updating (under Preferences > Editing > Plaint Text Font).

I’ve been attempting to change the color and background using the color picker, but it is not updating any of my text files. Sometimes, it will change the color ‘on-the-fly’, but as soon as I quit and come back or open another window and come back, it reverts back to the original text color.

Is there a way to reset my Preferences back to ‘factory’ default?

I tried deleting these but nothing happens:

Where are my color preferences stored? Thanks very much. -JP

I’m confused. DEVONthink > Preferences > Editing > Plain Text Font is for setting the display font for plain text files – not the document background or font color. Just the text.

There are settings in that Preferences panel for “Background” and “Text”, but those are for those colors when a document is displayed in full-screen mode (i.e., View > Full Screen > Document.

AFAIK, there’s no DEVONthink preference setting for plain text document background and text.

thanks for the reply, I didn’t know that about full screen mode. My color preferences indeed work fine in that mode.

My problem is that, in normal mode, all my text files look like this:

This came about when I tried to reverse the text color, because I prefer reading light on dark. I got the dark background part figured out, only problem is I can’t change the text color.

How do I reset this back to normal (black on white), or better yet change the font color to white?

OK, now I get it.

Try quitting DEVONthink. Navigate to ~/Library/Preferences/com.devon-technologies.thinkpro2.plist and move the preference file to the Desktop. Open DEVONthink. If the problem is resolved, then you can continue operating with the new preference file that DEVONthink just created. You might have to reestablish any changes you had previously made from the default preferences.

Deleting those preferences doesn’t work unfortunately, the text color remains the same.

What if you empty the cache (DEVONthink > Empty Cache)?

What if you make a plain text document in TextEdit and use the font you modified?

Emptying the cache doesn’t affect anything.

Not sure what you mean regarding TextEdit. TextEdit can’t create plain text files, only .rtf files evidently. My Devonthink can format rich text no problem.

I made a text file in Vim and imported it, and it’s still using my default black on black color scheme.

Anyways I appreciate your sincere efforts to help.

TextEdit can create plain text files per default, see preferences …

as well as on-the-fly:


DEVONthink Pro Office uses Apple’s text engine, therefore korm’s question. When strange things happen, sometimes rebooting your Mac helps.

ok thanks, I never knew that about TextEdit.

I’m able to modify TextEdit’s color preferences on-the-fly and customize the display of my plain text files. However it doesn’t save those color preferences in the file or in my TextEdit preferences either. Each time I open the file it reverts back to default black on white.

When I import those plain text files into Devonthink I get the same problem I’ve been experiencing.

I think I was able to replicate this problem - but when I tried to reproduce it a second time I was unable to. So I do not know the exact steps involved in repeating the error.

The plain text font setting is stored in the DEVONthink preference file (mentioned above in this thread) but only the font name is stored. In the preferences file there is also a setting for “TextBackground” and one for “TextForeground” – but I’m sure those refer to Full Screen Document viewing and not to the default color. So, perhaps there is an interaction with the system-wide font picker utility that’s not been explored here.

Changing the default plain text font setting in DEVONthink > Preferences > Editing to some other font should also fix the problem.

Obviously, though, that’s not the result that’s being reported.

I tried changing the font in preferences.

The font changes and updates, but alas the color doesn’t.

Short of uninstalling DEVONthink and reinstalling it, I’ve no more suggestions.