"Can't connect to Mail to get mail message data" when trying to add email to DT3.6

DEVONthink 3.6
Big Sur 11.0.1
MacBook Air M1

All Add-ons installed, Mail Plug-in checked in Mail prefs.

But if I try to send a message to DT3 from Mail > Menubar > Message > Add to DT3 there is a beep but nothing happens except another log entry.

It is working OK on my Intel iMac running Big Sur and DT3 3.6, so it would seem to be a universal app problem, unless I have missed a setting.


I just tried this successfully on a DTK. Does a reboot fix this?

Thanks but no a reboot hasn’t fixed it.

What is a DTK?

The ARM-based development kit, basically the first ARM-based Macs. Still waiting for my M1 Mac :slight_smile:

1 Like

Ah gotcha, one of the M1 Minis made available at the Devs Conference in the summer.

Are there any settings or permissions which might be relevant to this problem?

Maybe another M1 owner will chip in.

It isn’t a big deal as I don’t use it that often, and I can do it on my iMac, or export a PDF from Mail.

Other workarounds are e.g. drag & drop or scripts (see Scripts menu extra while Mail is active). You could also check that DEVONthink 3 has full disk access, see system preferences.

Thanks. yes DT3 has full disk access.

Got the same issue on my M1 MBA. Plugin enabled, full disk access for DTP 3.6.1. Running 11.1 version of Big Sur.

Mine is all working now, 3.6.1 on M1 MBA.

Have you enabled the DT3 plugin in Mail > Preferences > Manage Plugins?

Uninstalled the mail plugin and reinstalled the tool and all is working now.

Keep an eye on this to see if it recurs. .